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Tables 

You can use tables in your documents to arrange text 
and data neatly in a grid, organized by columns and 
rows. Once you’ve entered information into a table, 
you can style a table to stand out on the page or sort a 
table’s contents alphabetically or numerically. 

In this module, you’ll learn how to create tables from 
scratch or from existing text. You’ll also learn how to 
change a table’s size, position, and style, as well as how 
to sort a table’s contents. 

  

Objectives 

Create Tables 

Convert Tables 

Resize Rows and Columns 

Table Styles 

Table Borders and Shading 

Position a Table 

Cell Alignment and Margins 

Merge and Split Cells 

Sort a Table 

Row Headers and Page Breaks 
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Create Tables 

Tables are very useful tools when creating and formatting documents. For example, with a table you can: 

• Align Text, Numbers, and Graphics: Many people prefer to use tables for alignment instead of tab 
stops because text can wrap to multiple lines in a table. 

• Create a Form: You can use tables to store lists of telephone numbers, clients, and employee 
rosters. 

• Share Information: You can use tables to share information between programs. For example, you 
can copy and paste a table’s information into a Microsoft Excel worksheet or Access database. 

• Create a Publication: Tables make it easier to create calendars, brochures, business cards, and many 
other publications. 

Insert a Table 

To create a table, you must first determine how many columns (which run up and down) and rows (which 
run left to right) you want to appear in your table. Cells are small, rectangular boxes where the rows and 
columns intersect. The number of columns and rows determines the number of cells in a table. 

Click the Insert tab. 

Click the Table button. 

Use the grid to select how 
many columns and rows you’d 
like. 

The table with the specified 
number of rows and columns is 
inserted. 

Enter your content into your 
newly created table. 

You can use the arrow keys to navigate 
from cell to cell as you type. You can 
also press the Tab key to move to the 
next cell. 
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Add a Row or Column 

You can add more columns and rows to a table after you’ve inserted it. This way, you’re not trapped using a 
fixed structure if you need to add more data later. 

Select a cell in a row or column 
adjacent to where you want 
the new row or column 
inserted. 

Click the Layout tab in the 
Table Tools ribbon group. 

Click one of the Insert buttons 
in the Rows & Columns group. 

You can insert a row above or below 
the selected cell’s row, or a column to 
the left or right of the selected cell’s 
column. 

Tip: Hover your mouse above the line 
between columns, or to the left of the 
line between rows, and click the + 
button that appears to quickly add a 
new column or row. 
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Delete a Row or Column 

You can delete rows and columns that you don’t want, in case you made a table that was bigger than you 
needed. 

Select a cell in a row or column 
you want to delete. 

Click the Delete button on the 
Layout tab (in the Table Tools 
ribbon group). 

Here, you have the option to 
delete the specific cell, the 
column or row the selected cell 
is in, or the entire table. 

Select one of the options. 

If you decide to delete only the 
selected cell, you can choose how to 
move the rest of the cells around to fill 
the gap. You can shift the rest of the 
row’s cells to the left or shift the rest of 
the column’s cells up. 
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Convert Tables 

You don’t need to create a table from scratch every time. You can convert a selection of existing text into a 
table, as long as it’s properly formatted. You can also convert an existing table into regular text, in case you 
want to keep the data but don’t need it in a table. 

Convert Text to Tables 

If you have a lot of text already formatted properly, you can quickly turn it into a table. 

Select the text and make sure 
it’s properly formatted. 

Word will insert a new column 
when a tab character is found, 
so make sure that columns are 
separated by tabs. 

Click the Insert tab. 

Click the Table button. 

Select Convert Text to Table. 

If the text was formatted right, 
some of the options in this 
dialog box should already be 
filled in. Otherwise, set the 
number of columns and rows, 
and how to separate the text 
into columns. 

(Optional) Customize AutoFit 
behavior. 

You can choose whether to set 
a fixed column width, 
automatically fit the columns 
to the content, or 
automatically fit the table to 
the page or window. 

Click OK. 

The selected text is automatically 
turned into a table. 
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Convert Table to Text 

You can also convert an existing table back into plain text. This frees up the text from the table, so that you 
can keep the table’s data without the strict table formatting. 

With the table selected, click 
the Layout tab. 

Expand the Data group, if 
necessary. 

Click the Convert to Text 
button. 

Choose how you want the cells 
separated. 

You can separate the columns 
with new paragraph marks, 
tabs, or commas. You could 
also specify another custom 
separator. 

Click OK. 

The table is converted back to text. 
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Resize Rows and Columns 

When you first create a table, all the rows and columns will start the same size. As you add information to 
the table, you’ll likely find that some rows and columns will need to be bigger than others. You can adjust 
the size of rows and columns manually, or automatically resize them. 

Manually Resize 

The most direct way to manually adjust the width of a column or the height of a row is by directly adjusting 
them with the mouse. 

Click and drag a cell border 
until the row or column is the 
size you need. 

The columns or rows adjust to the new 
size. 
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Distribute Rows and Columns 

If your table has columns and rows of different sizes, you can distribute them so that they’re all the same 
width or height. 

Click the Layout tab in the 
Table Tools ribbon group.  

Click the Distribute Columns 
button or the Distribute Rows 
button.  

The columns or rows in the table are all 
set to the same width or height. 

  

EVALU
ATIO

N 

ONLY



 © 2025 CustomGuide, Inc. 17 

Automatically Resize 

You can also have rows and columns resize automatically to fit the table’s contents. 

Click the AutoFit button. 

The AutoFit menu has three 
options. 

• AutoFit Contents will 
automatically resize the 
rows and columns to fit the 
content in the cells. The 
table will automatically 
adjust to new content, 
resizing the columns and 
rows as you type. 

• AutoFit Window will resize 
the table to fill the available 
space on the page. 

• Fixed Column Width will 
stop the columns and rows 
from resizing as new content 
is added if you’ve previously 
enabled an AutoFit setting. 

Select an AutoFit option. 

The table’s rows and columns are 
resized according to the option you 
selected. 
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Table Styles 

Apply a Table Style 

By default, a table is created with the Table Grid style, which includes a basic black border around each cell 
in the table. Word includes many built-in styles that provide more visual appeal. 

Click inside the table. 

Click the Design tab in the 
Table Tools ribbon group. 

The Table Styles group will 
show a few table styles, but to 
see the rest, you’ll need to 
expand the gallery. 

(Optional) Click the Table 
Styles More button to see all 
the available styles. 

Select a style. 

The style is applied to the table, 
changing the borders, shading, and 
colors. 

Tip: You could create a new style by 
selecting New Table Style or modify an 
existing one by selecting Modify Table 
Style and choosing which formatting 
you’d like. 

Tip: To remove a Table Style, select 
Clear from the More Table Styles 
menu. 
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Adjust Style Options 

You can further customize a table style by changing the table style options. 

Use the check boxes in the 
Table Style Options group to 
toggle the following settings: 

• Header Row will apply 
special formatting to the 
first row of the table. This 
special formatting can 
include font effects, or font, 
background, and border 
color. 

• First Column will apply 
special formatting to the 
first column. 

• Total Row will add special 
formatting to the final row 
of a table, designed to 
summarize the rows above 
it.  

• Last Column will apply 
special formatting to the last 
column to summarize the 
earlier columns. 

• Banded Rows will alternate 
the background color of 
rows. 

• Banded Columns will 
alternate the background 
color of columns. 

Tip: The special formatting applied by 
each option is controlled by the style 
that’s been applied to the table. You 
can customize these formatting options 
by clicking the Table Styles More 
button, then selecting Modify Table 
Style. 
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Table Borders and Shading 

Add a Border 

Borders can improve a table’s appearance, giving it a polished, professional look. Borders also make it easier 
to keep the information in different cells visually separate. 

Select a cell, multiple cells, or 
the whole table. 

Borders will only be added to 
the cell or cells you have 
selected. 

Click the Design tab in the 
Table Tools ribbon group. 

Before applying a border, you 
need to specify the border 
style. You can individually 
select a line style, weight, and 
color, or use an existing border 
style. 

Click the Border Styles list 
arrow. 

This menu shows a few borders 
included in the document 
theme, in a variety of colors 
and line styles. 

Select a border style. 

Now that you’ve selected a 
border style, choose which 
borders to apply that style to. 

Click the Borders list arrow. 

This menu shows which borders 
the style can be applied to. You 
can select All Borders or a 
subset. 

Select the borders you want to 
add. 

The selected border style is applied to 
the selected borders. 

Tip: Select No Borders from the Borders 
menu to remove borders from the 
selected cells. 
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Add Cell Shading 

Shading includes fill colors and patterns that you can apply to table cells. 

Select the cell or cells you want 
to add shading to. 

Click the Shading list arrow on 
the Table Tools Design tab. 

The shading menu will show a 
spectrum of colors from the 
current document theme as 
well as a few standard colors. 
You could also select More 
Colors to select a custom color 
or select No Color to remove 
existing shading. 

Select a color. 

The color is added as a background to 
the selected cells. 

Tip: To use a pattern instead of a solid 
color in your table, click the Borders 
group dialog box launcher, click the 
Shading tab, and select a pattern in the 
Style list. 
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Position a Table 

Tables aren’t simply stuck where they are when you first insert them. You can move them around 
manually or let Word position them automatically for you. 

Align a Table 

You can position a table the same way that you position regular text, using the alignment controls. 

Select the table by clicking the 
Move handle ( ) that appears 
above the top left corner of the 
table. 

It’s important that the whole 
table is selected. If only certain 
cells are selected, the text in 
those cells will be aligned 
instead of the table. 

Select an alignment option in 
the Paragraph group on the 
Home tab. 

The table is aligned to the left, center, 
or right margin of the page, just like 
text would be. 
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Move a Table 

If the basic alignment options don’t position the table where you want it to be, you can move the table 
around the page manually. 

Click the table’s Move handle  
( ) and drag it to where you 
want to move the table. 

The table moves, and the text on the 
page moves around to make room. 

 

 

 

 

 

 

 

Adjust Text Wrapping 

Text wrapping controls how text in your document flows around a table. 

With the table selected, click 
the Layout tab in the Table 
Tools ribbon group. 

Click Properties. 

In the Text Wrapping section of 
the dialog box, you can choose 
from two text wrapping 
options. 

• None will clear the areas to 
the left and the right of the 
table. 

• Around will let the text 
wrap around the table on 
the left and right sides. 

Make your text wrapping 
selection. 

Click OK. 

The text wrapping is changed to the 
selected setting. 
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Resize a Table 

You can also easily resize a table to fit within a certain space. 

Click and drag the Sizing box in 
the bottom-right corner of the 
table to make your table larger 
or smaller. 

The table is resized, with the columns 
and rows resizing proportionally. 

Tip: You can also specify a preferred 
table width, but not height, in the 
Table Properties dialog box. 
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Cell Alignment and Margins 

Text Alignment 

You can control how text is aligned within a table cell, just like you’d align text on the page. 

Select the cell or cells you want 
to align. 

You could also select the entire 
table if you want to align all 
the text together. 

Click the Layout tab in the 
Table Tools ribbon group. 

Expand the Alignment group, if 
necessary. 

There are nine alignment 
options, letting you align the 
content to either side of a cell, 
any corner, or center it in the 
middle of the cell. 

Select an alignment option. 

The text in the selected cell realigns to 
the selected side or corner. 

Tip: You can also select Text Direction 
to change the text from left-to-right to 
top-to-bottom or bottom-to-top. 
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Add Cell Margins 

You can also adjust the margins between cell borders and the text within those cells. 

Select cell or cells you want to 
adjust. 

You can select the entire table 
to adjust all the margins at 
once. 

From the Layout tab, expand 
the Alignment group, if 
necessary. 

Click the Cell Margins button. 

In the Table Options dialog 
box, we can adjust the margins 
for the selected cell or cells. 
The margin affects how much 
space there is between the 
edge of the cell and the 
contents of that cell. 

Adjust the margins. 

You can adjust the margin on 
each side of the cell 
independently. 

Click OK. 

The cell margins are changed. 
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Merge and Split Cells 

Even though a table starts out as a strict grid of cells, you can change a table’s layout by merging multiple 
cells together, as well as splitting a cell into multiple cells. 

Merge Cells 

You can combine several smaller cells into a single, larger cell that spans the space previously occupied by 
the individual cells. 

Select multiple cells that share 
a border. 

Click the Layout tab in the 
Table Tools ribbon group. 

Click the Merge Cells button. 

The selected cells are merged into a 
single cell that takes up the entire 
width and height of the original cells. 

Tip: You can also right-click the 
selected cells and select Merge Cells 
from the menu. 
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Split Cells 

Cells can also be broken up into several smaller cells by using the Split Cells command. 

Select a cell. 

Click the Split Cells button in 
the Layout tab. 

Tip: You can also right-click a 
cell and select Split Cells from 
the menu. 

Enter the number of rows and 
columns you want the cell split 
into. 

Click OK when you’re done. 

The selected cell is split into the set 
number of columns and rows. 

 

 

 

Split Tables 

You can also split an entire table in two, letting you move part of it somewhere else. You can move the new 
part to another page, another document, or just add text or images in the space between the split table. 

Place the text cursor in the row 
that you want the second table 
to start with. 

Splitting a table will split it 
right above the selected line. 

Click the Split Table button. 

The table is split. EVALU
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Sort a Table 

Word can sort data in a table alphabetically, numerically, or chronologically (by date). In addition, it can sort 
information in ascending (low to high / A to Z) or descending (high to low / Z to A) order. You can sort an 
entire table or a portion of a table by selecting what you want to sort. 

Sort Tables 

Click inside the table. 

You can also select a range of 
cells to sort just those cells. 

Click the Layout tab in the 
Table Tools ribbon group. 

Expand the Data group, if 
necessary. 

Click the Sort button. 

Set up your sort criteria. 

The initial options selected in 
this dialog box will be 
automatically set based on the 
data in the table. 

• First, select which column to 
sort by. If your table has a 
header row, you’ll be able to 
see the column names in the 
first list field. Otherwise, the 
columns will simply be 
numbered. 

• Next, select how to sort, 
either by Text, Number, or 
Date. 

• Finally, choose whether to 
sort in Ascending or 
Descending order. 

Tip: To sort by multiple criteria, 
add additional sort choices 
with the Then by dropdown. 

Click OK. 

The table is rearranged, as the data is 
sorted by the criteria you set. 
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Row Headers and Page Breaks 

If you have a large table that spans across several pages, you have a few options to control its appearance. 

Repeat Row Headers 

If the table has a header row, you can repeat it on the top of each page. 

Select the header row. 

Click the Layout tab in the 
Table Tools ribbon group. 

Expand the Data group, if 
necessary. 

Click the Repeat Header Rows 
button. 

The header row will now be 
automatically repeated whenever the 
table appears across multiple pages. 

To turn this off, just click the Repeat 
Header Rows button again. 
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Adjust Page Break Options 

Occasionally, a table will get split up over a page break, making it difficult to consume. Word has settings to 
prevent this from happening. 

Select the table. 

Click the Properties button on 
the Layout tab. 

The Table Properties dialog box 
opens. 

You can also right-click the 
table and select Table 
Properties from the menu. 

Click the Row tab. 

The Row properties let you 
control the height of the row, 
as well as two options for how 
the row appears when the 
table spans multiple pages. 

• Allow rows to break across 
pages toggles whether the 
row can be split when the 
table expands to another 
page. When turned off, the 
row will move to the next 
page entirely instead of 
splitting. 

• Repeat as header row at 
the top of each page lets 
you use the selected row as 
a header. 

Clear the Allow row to break 
across pages check box. 

Click OK. 

Any previously broken rows move to 
the next page to keep the rows intact. 
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