
 

 
 
  

Excel 

[Your Company Name] 

Advanced 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

© 2025 by CustomGuide, Inc. 3387 Brownlow Avenue, Suite 200; Saint Louis Park, MN 55426 

This material is copyrighted and all rights are reserved by CustomGuide, Inc. No part of this publication 
may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language 
or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical, 
manual, or otherwise, without the prior written permission of CustomGuide, Inc. 

We make a sincere effort to ensure the accuracy of the material described herein; however, CustomGuide 
makes no warranty, expressed or implied, with respect to the quality, correctness, reliability, accuracy, or 
freedom from error of this document or the products it describes. Data used in examples and sample data 
files are intended to be fictional. Any resemblance to real persons or companies is entirely coincidental. 

The names of software products referred to in this manual are claimed as trademarks of their respective 
companies. CustomGuide is a registered trademark of CustomGuide, Inc.

EVALU
ATIO

N 

ONLY



 © 2025 CustomGuide, Inc. iii 

Contents 

PivotTables ................................................................................................................................................ 7 

Create PivotTables .......................................................................................................................................... 8 

Create a PivotTable ..................................................................................................................................... 8 

Add PivotTable Fields .................................................................................................................................. 9 

Add Multiple PivotTable Fields ..................................................................................................................... 10 

Add an Additional Row or Column Field ................................................................................................... 10 

Expand or Collapse a Heading ................................................................................................................... 11 

Add an Additional Value Field ................................................................................................................... 11 

Change a PivotTable’s Calculation ................................................................................................................ 12 

Change PivotTable Calculations ................................................................................................................ 12 

Add Calculated Fields .................................................................................................................................... 13 

Create a Calculated Field .......................................................................................................................... 13 

Remove a Calculated Field ........................................................................................................................ 14 

The GETPIVOTDATA Function ....................................................................................................................... 15 

Use the GETPIVOTDATA Function ............................................................................................................. 15 

Filter PivotTables ........................................................................................................................................... 16 

Add a Filter Field ....................................................................................................................................... 16 

Clear a Filter .............................................................................................................................................. 17 

Remove a Filter ......................................................................................................................................... 17 

Timelines ....................................................................................................................................................... 18 

Insert a Timeline ....................................................................................................................................... 18 

Clear a Timeline ........................................................................................................................................ 19 

Remove a Timeline .................................................................................................................................... 19 

PivotTable Layout .......................................................................................................................................... 20 

PivotTable Layout Options ........................................................................................................................ 20 

Group Values ................................................................................................................................................. 21 

Group PivotTable Values ........................................................................................................................... 21 

Ungroup PivotTable Values ....................................................................................................................... 22 

Refresh a PivotTable ..................................................................................................................................... 23 

Manually Update a PivotTable .................................................................................................................. 23 

Automatically Update a PivotTable .......................................................................................................... 24 

Format a PivotTable ...................................................................................................................................... 25 

Work with Style Options ........................................................................................................................... 25 

EVALU
ATIO

N 

ONLY



iv [Your Company Name] 

Apply a Built-In Style .................................................................................................................................. 26 

PivotCharts .............................................................................................................................................. 27 

Create PivotCharts ......................................................................................................................................... 28 

Insert a PivotChart ..................................................................................................................................... 28 

Modify a PivotChart ................................................................................................................................... 29 

PivotChart Options ........................................................................................................................................ 30 

Refresh a PivotChart .................................................................................................................................. 30 

Use the Field Buttons ................................................................................................................................ 30 

Change Chart Layout ................................................................................................................................. 31 

Use Quick Layouts ..................................................................................................................................... 31 

PivotChart Styles ............................................................................................................................................ 32 

Apply a PivotChart Style ............................................................................................................................ 32 

Change Chart Colors .................................................................................................................................. 33 

Drill Down Data ............................................................................................................................................. 34 

Use Drill Down Buttons ............................................................................................................................. 34 

Drill Down into Specific Chart Data ........................................................................................................... 35 

Troubleshoot Formulas ............................................................................................................................ 37 

Formula Errors ............................................................................................................................................... 38 

#### Error .................................................................................................................................................. 38 

#NAME? Error ............................................................................................................................................ 39 

#VALUE! Error ............................................................................................................................................ 40 

#DIV/0! Error ............................................................................................................................................. 41 

#REF! Error ................................................................................................................................................. 41 

The Watch Window ....................................................................................................................................... 42 

Add Cells to the Watch Window ............................................................................................................... 42 

Evaluate Formulas ......................................................................................................................................... 44 

Evaluate a Formula .................................................................................................................................... 44 

Advanced Formatting ............................................................................................................................... 45 

Customize Conditional Formatting ................................................................................................................ 46 

Create a Custom Conditional Formatting Rule .......................................................................................... 46 

Conditional Formatting with Formulas .......................................................................................................... 47 

Use Formulas with Conditional Formatting ............................................................................................... 47 

Manage Conditional Formatting ................................................................................................................... 48 

Edit a Conditional Formatting Rule ........................................................................................................... 48 

Change the Order of Conditional Formatting Rules .................................................................................. 50 

International Currency and Formats ............................................................................................................. 51 

EVALU
ATIO

N 

ONLY



 © 2025 CustomGuide, Inc. v 

Change the Windows Regional Format Settings ....................................................................................... 51 

Apply an International Currency Format .................................................................................................. 53 

Display a Date or Time in a Different International Format ..................................................................... 53 

Body and Heading Options ........................................................................................................................... 55 

Apply a Theme Font Set ............................................................................................................................ 55 

Create a Custom Font Set ......................................................................................................................... 56 

Color Formats ................................................................................................................................................ 57 

Apply a Color Scheme ............................................................................................................................... 57 

Create a Custom Color Scheme ................................................................................................................ 58 

Custom Themes ............................................................................................................................................ 59 

Apply Theme Elements ............................................................................................................................. 59 

Create a Custom Theme ............................................................................................................................ 60 

Form Controls ............................................................................................................................................... 61 

Turn on the Developer Tab ....................................................................................................................... 61 

Insert a Form Control ................................................................................................................................ 63 

Save Form Templates .................................................................................................................................... 65 

Save a Form as a Template ....................................................................................................................... 65 

Open a Form Template ............................................................................................................................. 66 

Advanced Formulas ................................................................................................................................. 67 

IF Function ..................................................................................................................................................... 68 

Insert an IF Function ................................................................................................................................. 68 

Nested Functions .......................................................................................................................................... 69 

Insert a Nested Function ........................................................................................................................... 69 

AND, OR, and NOT Functions ........................................................................................................................ 70 

Insert an AND, OR, or NOT Function ......................................................................................................... 70 

SUMIF, AVERAGEIF, and COUNTIF Functions ............................................................................................... 71 

Create a SUMIF Formula ........................................................................................................................... 71 

VLOOKUP ....................................................................................................................................................... 73 

Insert a VLOOKUP Function ...................................................................................................................... 73 

HLOOKUP ...................................................................................................................................................... 76 

Insert an HLOOKUP Function .................................................................................................................... 76 

INDEX and MATCH ........................................................................................................................................ 79 

The INDEX Function .................................................................................................................................. 79 

The MATCH Function ................................................................................................................................ 81 

Combine the INDEX and MATCH Functions .............................................................................................. 82 

UPPER, LOWER, and PROPER ........................................................................................................................ 84 

UPPER Functions ....................................................................................................................................... 84 

EVALU
ATIO

N 

ONLY



vi [Your Company Name] 

LOWER Function ........................................................................................................................................ 85 

PROPER Function ....................................................................................................................................... 86 

RIGHT, LEFT, and MID .................................................................................................................................... 87 

The LEFT Function ...................................................................................................................................... 87 

The RIGHT Function ................................................................................................................................... 88 

The MID Function ...................................................................................................................................... 89 

Formula Calculation Options ......................................................................................................................... 90 

Change the Formula Calculation Options .................................................................................................. 90 

Analyze Data ............................................................................................................................................ 91 

Goal Seek ....................................................................................................................................................... 92 

Use Goal Seek ............................................................................................................................................ 92 

Scenario Manager .......................................................................................................................................... 94 

Use Scenario Manager ............................................................................................................................... 94 

View a Scenario Summary ......................................................................................................................... 96 

Consolidate Data ........................................................................................................................................... 97 

Consolidate Data ....................................................................................................................................... 97 

Macros ................................................................................................................................................... 101 

Enable Macros ............................................................................................................................................. 102 

Enable Macros in a Single File ................................................................................................................. 102 

Set Trusted Locations .............................................................................................................................. 103 

Macro Settings ......................................................................................................................................... 106 

Create Macros ............................................................................................................................................. 107 

Record a Macro ....................................................................................................................................... 107 

Run a Macro ............................................................................................................................................ 109 

Modify Macros ............................................................................................................................................ 110 

Unhide the Personal Workbook .............................................................................................................. 110 

Edit a Macro ............................................................................................................................................ 111 

Test an Edited Macro ............................................................................................................................... 112 

Copy Macros ................................................................................................................................................ 113 

Copy Macros from Another Workbook ................................................................................................... 113 

Test a Copied Macro ................................................................................................................................ 114 

 

EVALU
ATIO

N 

ONLY



 © 2025 CustomGuide, Inc. 7 

PivotTables 

PivotTables are one of the most powerful features in 
Excel, and they’re surprisingly quick to build, too. With 
properly organized source data, you can create a 
PivotTable to summarize and analyze data ranges in 
just a couple of minutes. There are endless possibilities 
for structuring your data in a PivotTable, so you’ll want 
to have a good idea of what you want to measure or 
understand before you start. 

PivotTables are good for grouping or expanding levels 
of data, transforming columns into rows and vice versa 
(“pivoting” data), and filtering and sorting data. They 
lend themselves particularly well to forming a concise 
summary from long lists of data. They can be used to 
build dynamic reports in a fraction of the time it would 
take to do so manually, helping you make informed 
decisions. 

This module explains how to create PivotTables, 
modify their structure and formatting, use timelines, 
and group values. Once you’ve mastered PivotTables, 
you’ll discover there are a variety of ways you can use 
them to add value to your projects. 

  

Objectives 

Create PivotTables 

Add Multiple PivotTable Fields 

Change a PivotTable’s Calculation 

Add Calculated Fields 

The GETPIVOTDATA Function 

Filter PivotTables 

Timelines 

PivotTable Layout 

Group Values 

Refresh a PivotTable 

Format a PivotTable 
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Create PivotTables 

When faced with a worksheet packed full of data, with many columns and perhaps hundreds or thousands 
of rows, making sense of it all can be a daunting task. PivotTables help you pull out just the data you need to 
quickly make informed decisions. They are very flexible, easy to adjust, and can be created and modified 
with just a few clicks. Don’t worry if PivotTables are confusing at first, they will make a lot more sense once 
you start working with them. 

Before you start creating one, it’s important to keep a few basic rules in mind: 

• Your data should be neatly organized into rows and columns without any blank rows or columns. 

• Each column should have the same data type. For example, you shouldn’t have a column of prices 
where some cells have the currency format applied and some have the accounting format applied. 

• PivotTables can be created using a cell range or an existing table. 

Create a PivotTable 

Select any cell in the data 
range you want to analyze. 

Click the Insert tab on the 
ribbon. 

Click the PivotTable button in 
the Tables group. 

The Create PivotTable dialog 
box opens. Here, choose which 
data to analyze and where to 
place the PivotTable. 

If you’ve already clicked within 
a data range, the Table/Range 
field is populated. Verify the 
correct range is displayed. 

Tip: The data range doesn’t 
have to be in the current 
workbook. Select Use an 
external data source to select 
data outside the workbook. 

Click OK. 

An empty PivotTable and task pane 
appear on a separate worksheet. Next 
you need to specify the fields you want 
to appear in your PivotTable. 
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Add PivotTable Fields 

Once you’ve created your PivotTable, you have to specify the data you want to analyze. The PivotTable 
Fields pane appears at the right. Under the Search field you see a list of all the possible fields you can use in 
your PivotTable. These fields are the column headings from the original data source. 

To make it a little easier to understand, let’s break it down. Say your original data set contains information 
for ticket sales and includes dates, destinations, prices, the number of sales, sales totals, sales agents, etc., 
but all you really need to know is how many tickets were sold each month for each destination. You can grab 
the Destination field and the Date field, add them as rows and columns in the PivotTable, and add a numeric 
sales field to the values area. The PivotTable will display a subset of the original data, but only include the 
values you really need to see. 

Click and drag a field to the 
Rows area. 

Click and drag a field to the 
Values area. 

If desired, click and drag a field 
to the Columns area. 

Tip: If you want to filter the 
PivotTable, add an additional 
field to the Filters area. 

The PivotTable updates to display the 
values for the fields you’ve added. The 
great thing about PivotTables is they 
are extremely flexible. If the table isn’t 
displaying the data like you want, just 
click and drag fields in and out of the 
Rows, Values, and Columns areas until 
the PivotTable represents the data 
correctly. 
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Add Multiple PivotTable Fields 

When adding fields to the Filters, Columns, Rows, and Values areas of a PivotTable, you aren’t limited to just 
adding one field; you can add as many as you like. However, if you make it too complex, the PivotTable will 
start to become difficult to consume. You may need to experiment with adding multiple fields to certain 
areas to see what works best for your set of data. Remember, you can always drag fields out of the area 
you’ve added them to in the PivotTable Fields pane to remove them. 

Let’s refer back to our previous example, where we are only interested in seeing the monthly sales for each 
destination. After creating the PivotTable, your boss may request to see data for which agents made those 
sales. Instead of creating a separate PivotTable, you can easily add the Name field as an additional row to 
expand the data that’s represented. 

Add an Additional Row or Column Field 

Click any cell in the PivotTable. 

The PivotTable Fields pane 
appears. 

Tip: You can also turn on the 
PivotTable Fields pane by 
clicking the Field List button on 
the Analyze tab. 

Click and drag a field to the 
Rows or Columns area. 

The PivotTable is updated to include 
the additional values. The order you 
place the fields in each area in the 
Fields pane affects the look of the 
PivotTable. You can drag the field 
values up or down within an area (the 
Rows area, for example) to adjust which 
data appears first. 

Note: Some fields, when added to a 
PivotTable, will automatically be 
displayed as two fields. For example, 
when adding a date field to the 
Columns area, Excel will likely group the 
dates into months automatically instead 
of displaying each individual date as a 
column heading. In the Columns area of 
the PivotTable Fields pane, you’ll see 
two fields—Date and Months—even 
though you only added a single field. 
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Expand or Collapse a Heading 

Once you’ve added more than one value to an area, expand and collapse buttons appear for the top-level 
values in the PivotTable. Use these to change how much of the data is visible at once. 

Click the Expand or Collapse 
symbol next to a row or 
column heading. 

 

 

 

 

 

 

 

 

 

Add an Additional Value Field 

If your original set of data has multiple columns with numeric values, you may find yourself adding 
additional fields to the Values area. If this is the case, the PivotTable will display the sum of one set of data 
followed by the sum of the second set of data in an adjacent column. 

Click and drag a second field to 
the Values area. 

The order in which you place the fields 
in the Values area is very important. If 
you add a field and the PivotTable 
doesn’t look right, try adjusting the 
order of the fields until the PivotTable 
displays useful data. 
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Change a PivotTable’s Calculation 

Besides adjusting the layout of your PivotTable data, you can also change how a PivotTable summarizes 
values. For example, you might want a PivotTable to display averages instead of totals. 

Change PivotTable Calculations 

Click any cell inside the 
PivotTable. 

Click the Analyze tab on the 
ribbon. 

Click the Active Field button on 
the ribbon. 

Click Field Settings. 

The Value Field Settings dialog 
box appears. From here, you 
can select calculation options 
including Sum, Count, Average, 
or Max, among others.  

Tip: When a field containing 
numeric values is added to a 
PivotTable, Excel automatically 
calculates the sum. 

Select the type of calculation 
you want to use. 

Click OK. 

The summarized data in the PivotTable 
changes to use the new calculation. 
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Add Calculated Fields 

A calculated field is a new field that performs calculations based on existing fields in your PivotTable. For 
example, you could use a calculated field to find the average ticket sales using an existing total sales field 
and a field containing the number of tickets sold. 

Create a Calculated Field 

Click a cell in the PivotTable. 

Click the Analyze tab. 

Expand the Calculations group, 
if necessary. 

Click the Fields, Items, & Sets 
button. 

Select Calculated Field. 

The Insert Calculated Field 
dialog box displays. This is 
where you’ll create and name 
the field. 

Type a name for the calculated 
field in the Name field. 

Click in the Formula field. 

Enter a calculation using the 
fields in the list and/or custom 
values. 

Tip: You can also enter your 
own values in the formula. For 
example, you could find a 
monthly average by adding an 
existing field and then dividing 
by 12. 

Click OK. 

The new calculated field is 
automatically added to the PivotTable. 
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Remove a Calculated Field 

If you decide you don't need the calculated field in your PivotTable, it can be removed just like any other 
PivotTable field. 

Uncheck the calculated field in 
the PivotTable Fields pane. 

The calculated field is removed from 
the PivotTable; however, it remains in 
the field list to use again in the future. 

Note: If you want to remove the 
calculated field completely, you need 
to re-open the Insert Calculated Field 
dialog box, select the field you created 
in the Fields list, and click the Delete 
button. 
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The GETPIVOTDATA Function 

The GETPIVOTDATA function is used to extract data from your PivotTable. You place the function in a cell 
outside of the PivotTable, and it uses data within the table to perform a calculation. The syntax for the 
GETPIVOTDATA function looks like this: =GETPIVOTDATA (data_field, pivot_table, [field1, item1], ...). You fill 
in the function with the following information: 

• data_field: The name of the field in the PivotTable you want to query. 

• pivot_table: Any cell located in the PivotTable. 

• field1, item1 (Optional): The field or item you wish to reference. 

Use the GETPIVOTDATA Function 

Click in a cell outside the 
PivotTable where you want to 
add the function. 

Type the = sign. 

Click the cell in the PivotTable 
that contains the data you 
want to extract. 

As soon as you type = and click 
within the PivotTable, the 
GETPIVOTDATA function is 
automatically added. 

(Optional) Expand the function 
to include additional 
calculations. 

The advantage of using the 
GETPIVOTDATA function instead of a 
cell reference is that it records data to 
ensure the correct value is returned, 
even if the location of the referenced 
cell changes when the data in a 
PivotTable is updated. 

Tip: If you happen to be using cube 
functions as part of your Excel 
workbooks, note the GETPIVOTDATA 
function has almost all of the 
expressions you'll need for your cube 
functions. You can paste these 
GETPIVOTDATA values into your cube 
functions to save time and simplify the 
process. 
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Filter PivotTables 

Much like you can with basic data ranges and tables in Excel, you can filter a PivotTable to focus in on a 
smaller portion of data. 

For example, instead of showing the sales values for every destination, you can add the Commission field as 
a report filter to show only the sales for which an agent earned a commission. 

Add a Filter Field 

Click any cell in the PivotTable. 

Drag a field to the Filters area 
in the PivotTable Fields pane. 

The filter field appears at the 
top of the PivotTable. The text 
(All) is displayed so you know 
the data is not currently being 
filtered. 

Click the list arrow for the field 
you’ve added as a filter. 

A list of sorting and filtering 
options appears. The items 
available in the menu will differ 
based on the field you’ve 
added as a filter. Additionally, 
a Search field appears at the 
top of the filter list. If desired, 
manually type the criteria by 
which you want to filter. 

Tip: You can also filter the row 
or column headings in a 
PivotTable by clicking the Row 
Labels or Column Labels list 
arrow and selecting only the 
value(s) you want to display. 

Select the item(s) you want to 
use as a filter. 

Click OK. 

The PivotTable updates to display only 
the values that meet the filter criteria.  
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Clear a Filter 

Once you’re done analyzing the filtered data, clear the filter to see all the data in your PivotTable again. 

Click the filter icon next to the 
filter field. 

Select All. 

Click OK. 

The filter is cleared from the 
PivotTable, showing all the data once 
again. 

 

 

 

 

 

Remove a Filter 

When a filter is cleared, all the data is visible; however, the filter remains in the PivotTable to use again. If 
you want the filter gone completely, you’ll need to remove it. 

Click and drag the field out of 
the Filters area. 

Tip: You could also uncheck the 
field in the fields list. 

The filter is removed from the 
PivotTable entirely. 
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Timelines 

Timelines are interactive filters that let you quickly filter by date. They make it quick and easy to see 
PivotTable data for only the time period you specify. They are similar to slicers in that you can insert them 
once and keep them with the PivotTable to update at will. 

Insert a Timeline 

Click any cell inside the 
PivotTable. 

Click the Analyze tab on the 
ribbon. 

Click the Insert Timeline 
button. 

Tip: You can also insert a 
Timeline for PivotCharts and 
cube functions. 

The Insert Timelines dialog box 
appears. It automatically 
detects the date fields used in 
the PivotTable and has them 
available for you to select 
from. Many times, there will 
only be one available field. 

Select the date field you want 
to use for the timeline. 

Click OK. 

Select a time span in the 
Timeline you want the 
PivotTable to display.  

Tip: To select multiple 
intervals, you can click and 
drag along the timeline or click 
the first interval you want to 
include and hold the Shift key 
while clicking the last interval 
in your chosen span. 
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Clear a Timeline 

You can clear the Timeline at any point to restore all the data in the PivotTable. 

Click the Clear Filter button at 
the top-right corner of the 
Timeline. 

All the PivotTable data is visible once 
again. 

 

 

 

 

 

 

Remove a Timeline 

If you no longer need to use the Timeline, it can be removed from the sheet entirely. 

Right-click the timeline. 

Select Remove Timeline. 

The timeline is removed from your 
PivotTable. 

 

  

EVALU
ATIO

N 

ONLY



20 [Your Company Name] 

PivotTable Layout 

There are several options for altering the layout of your PivotTable. The Layout group on the Design tab 
allows you to change what elements appear on the PivotTable. 

PivotTable Layout Options 

Click any cell inside the 
PivotTable. 

The Analyze and Design tabs 
appear under PivotTable Tools 
on the ribbon. 

Click the Design tab on the 
ribbon. 

The Layout group has options 
to change which elements 
appear in your PivotTable. 

• Subtotals: Click to show or 
hide subtotals, and to 
specify where to show 
them. 

• Grand Totals: Click to show 
or hide grand totals, and to 
specify whether they appear 
for rows, columns, or both. 

• Report Layout: Show the 
PivotTable in compact, 
outline, or tabular form. 

• Blank Rows: Insert or 
remove a blank line 
between each grouped item 
in the PivotTable. 

Click the Layout button for the 
element you want to update. 

A list of options appears, 
depending on the button that 
was selected. 

Select an option from the list. 

The PivotTable layout is updated based 
on your selection. 
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Group Values 

You can group PivotTable data in order to set it apart from additional subsets of data. You can group most 
items, but dates are a common item to group. For example, you may want to group the information in the 
PivotTable by days, months, quarters, or years. 

Group PivotTable Values 

Click any cell that has a value 
you want to group by. 

Click the Analyze tab on the 
ribbon. 

Click the Group Field button. 

Tip: You can also right-click a 
cell and select Group from the 
menu. 

The Grouping dialog box 
appears. 

Specify how you want to group 
your PivotTable. 

When grouping date values, 
the default starting and ending 
dates are the first and last 
dates in the PivotTable. 

Tip: To group dates by weeks, 
select Days in the By area of 
the Grouping dialog box and 
enter 7 in the Number of days 
field below the list. 

Click OK. 

The PivotTable groups together all the 
data. 

  EVALU
ATIO

N 

ONLY



22 [Your Company Name] 

Ungroup PivotTable Values 

If you decide you want to see the individual values as column headers again, just ungroup them. 

Click a cell that contains the 
value you want to ungroup. 

Click the Ungroup button on 
the Analyze tab. 

Tip: You can also right-click a 
cell and select Ungroup from 
the menu. 

The grouping is removed from the 
PivotTable. 
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Refresh a PivotTable 

If you make changes to the source data a PivotTable is based on, the PivotTable isn’t automatically updated. 
Instead, you must manually refresh the PivotTable anytime you change its underlying source data. 

Manually Update a PivotTable 

Make a change to the 
PivotTable’s source data. 

Navigate to the PivotTable. 

Click any cell inside the 
PivotTable. 

The PivotTable Tools are 
displayed on the ribbon. 

Click the Analyze tab on the 
ribbon. 

Click the Refresh button. 

Tip: Alt + F5 also refreshes the 
PivotTable. 

The PivotTable is refreshed and pulls in 
any changes made to the source data. 

If you have more than one PivotTable 
in your workbook and you want to 
update them all at once, instead click 
the Refresh button’s list arrow and 
select Refresh All from the menu. 
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Automatically Update a PivotTable 

You can also have Excel refresh the PivotTables in a workbook when a file opens. 

Click the PivotTable button on 
the Analyze tab. 

Click Options. 

The PivotTable Options dialog 
box displays. In addition to 
setting the PivotTable to 
refresh when opened, there 
are also various options here 
for PivotTable settings, such as 
assigning a name; changing the 
layout, format, and display 
settings; and adding alt text. 

Click the Data tab. 

Check the Refresh data when 
opening the file check box. 

Click OK. 

Now any PivotTables in the workbook 
will automatically refresh each time 
you open the file. 
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Format a PivotTable 

After creating a PivotTable, you may want to enhance the look of it using styles. By default, the column 
headings, grand total row, and any filters have a light shading applied to the cells based on the workbook’s 
theme colors. However, if you don’t like these, there are a variety of other styles to choose from. 

Work with Style Options 

You can select PivotTable style options that allow you to adjust the format for part of a PivotTable. For 
example, you can apply special formatting to row headers or make the columns banded. 

Click any cell in the PivotTable. 

Click the Design tab. 

Select an option from the 
PivotTable Style Options group. 

• Row/Column Headers: 
Displays special formatting 
for the first row or column 
of the PivotTable. 

• Banded Rows/Columns: 
Applies a different format to 
alternate rows or columns. 
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Apply a Built-In Style 

Excel also has a gallery of built-in styles you can choose from to quickly format a PivotTable. 

On the Design tab, select an 
option in the Styles gallery. 

Tip: The PivotTable Styles 
group will show a few table 
styles, but to see the rest, 
you’ll need to expand the 
gallery. 

The style is applied to the table, 
changing the borders, shading, and 
colors. 

Tip: To remove a Table Style, select 
Clear from the More PivotTable Styles 
menu. 
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