Excel
Advanced

Instructor Guide /

[Your Company Name] CUStom




© 2025 by CustomGuide, Inc. 3387 Brownlow Avenue, Suite 200; Saint Louis Park, MN 55426

This material is copyrighted and all rights are reserved by CustomGuide, Inc. No part of this publication
may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language
or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical,
manual, or otherwise, without the prior written permission of CustomGuide, Inc.

We make a sincere effort to ensure the accuracy of the material described herein; however, CustomGuide
makes no warranty, expressed or implied, with respect to the quality, correctness, reliability, accuracy, or
freedom from error of this document or the products it describes. Data used in examples and sample data
files are intended to be fictional. Any resemblance to real persons or companies is entirely coincidental.

The names of software products referred to in this manual are claimed as trademarks of their respective
companies. CustomGuide is a registered trademark of CustomGuide, Inc.



Contents

PIVOTAbIES ... w7
Create PIVOTTAbBIES .......cuiiiiiiii s 8
Create @ PivOtTable ... 8
Add PivotTable Fields........cccciiiiiiiiiiii s 9
Add Multiple PIVOTTAbIE FIEIAS ...ccueeieiiiiiiiieeieetete sttt st st sae e sttt saeesiee e e e 10
Add an Additional Row or Column Field .........cccooiiiiiiiiiiiii e 10
Expand or Collapse @ HEAUING......cocuiiiiiiieieese ettt sttt e st e e bt e st e saae e esanae e 11
Add an Additional Value Field..........ccccoiiiiiiiiiiii e 11
Change a PivotTable’s CalCUIatioN .......ccueiiiieiiiiiieiiie ettt sttt bee st e e sae e st e sbaeebeenanes 12
Change PivotTable CalCUIatioNs ........ueeiuieiiieiieeiie ettt sttt et e st bae s beesbeesaee st enbaesbeesanes 12
Add Calculated FIelds ..o 13
Create a Calculated Field .........cocoiuiiiiiiiiii e 13
Remove a Calculated Field...........coiiiiiiiiiiiii 14
The GETPIVOTDATA FUNCLION ....vcuiiiiiiciiieteiti ittt ettt s 15
Use the GETPIVOTDATA FUNCLION ......ciiiiiiiiiiiciic s sars s 15
Filter PIVOTTABIES. ....oviiiiiiiic e 16
Add @ FIEEr FIRId ... e 16

Clear a Filter....

Remove a Filter ..

THMEIINES ..ottt ee ettt et e bt et e bt et e s bt e st saeeae e s e ea e e b e et e eh e e e e e bt et e e he et e et et bt et e nneeneens 18
INSEIT @ TIMEIINE .ttt e h bt e b et e b et b e st et e b e sae e besae e benaeeeenne e 18
ClEAr @ TIMEIINE ..ottt b et b et e s bt et e e et e ae et e e bt e et eae et e eseeeeeneeeennenne 19
REMOVE @ TIMEIINE ...ttt sttt et sb et h et ese b e e st et e sae et e saeennenaeeanenens 19

PIVOTTADIE LAYOUL... ittt sttt ettt sttt st ettt et et e e st et sk ebe et e s st es b e saeenseseeeneetesaeseentenne 20
PIVOLTabIE LAYOUL OPTIONS ....viutieiietietieteete ettt ettt ettt ettt st bt be et e besate b esteseaesaeesesbeennesbeeanen 20

GIOUP VAlUBS ..ttt sttt sttt se bbb s bt e st e s bt e s e s aeeat et e bt eh e e b e e bt e e e e bt et e s beensanebesatenbenaee 21
GrOUP PIVOTTADIE VAlUES.....couiieeiieieet ettt st st bbbt e st s e e nbesaeenne 21
UNEGroup PIVOLTADIE VAIUES....c..oouiiiiiiieeiee ettt ettt st st st sa e sbeeanes 22

REFrESh @ PIVOTTADIE ...ttt st et s bt sa et e bt et e s b e n e besnnenenne 23
Manually Update @ PIvOTTable .....c..couiiiiieriee ettt st st 23
Automatically Update @ PIVOLTADIE ......oouiiiiiieierieeieseeee ettt 24

FOrmat @ PIVOTAbIe c....couiiiiiiiiiiiee et sren s 25
WOTrK With STYIE OPLIONS ...eiviiiiieciieiee ettt et sre et e et e st et e et eesbaeebeesabeesaeesasbeeenbeesaseeseesnseennns 25

© 2025 CustomGuide, Inc. iii



APPIY @ BUIE-IN SEYIB ..ttt st e e e s et e e se e tetesbeentesseeneensaessensanseenens 26

PivotCharts

Create PivotCharts.....

Insert a PivotChart

MOAIfY @ PIVOTCRAIT ...ttt b et bbb se b st b e sb e s e sb e e s enbe et en s 29
PIVOTCRAIT OPTIONS ..ttt ettt bt b et b et e bt et e beb e e st e saeeatesa e ese e s e enee et e ibeennen 30
Refresh @ PIVOTCNAIt.......c..ciiiiiiic e s 30
Use the FIield BULLONS ..o 30
ChaNEE CNArt LAYOUL ..c.viiieiiiiieiieesits et se et ste ettt e s ee et e et e s beesaaeeaeesabeesseeenseetessaesabessssesaseessbeanseaans 31
USE QUICK LAYOULS ...veeiiieiieetiesite et e siite et e stae et esebeestaesabeeteesbeessbeesbaesabeesaseeaseeeaenseeesbeenssesnbeesasaeseesssassenn 31
PIVOTCRAIT SEYIES ... ettt sttt ettt ettt e bt et e sae et se b ea e seeeatesenaeeneenees 32
APPIY @ PIVOTCNAIT STYIE ..ttt ettt ettt st b et b e st b e st st esee e s e nbesaeen 32
ChaNE Chart COIOIS . .eieieiieieiitete ettt ettt sttt st ettt ettt et e et e sa e abeseseeeat e st e eaeenbesaeenbesaeennene 33
DIl DOWN DAtA .ottt e st b ea et b et be b sb e b ene 34
USE DIill DOWN BULLONS ...viiiiiiiiiiiie ittt st et e s s 34
Drill DOWN int0 SPECIfic Chart DAta ......coveruerierieniieieesieneet ettt sttt ettt st st sesesaeenes 35
Troubleshoot Formulas...........cccerureiuinnnenn. oI EU B Wi nae e seasesennensasensens 37
FOrMUIA EFTOTS ottt en 38
222 g o S 38
HINAME? EFTOF oottt e b s en 39
HVALUED EFTOF ottt bbb bbbt 40
EI DTNV e 41
Y o ST 41
The Watch WINOW ... bbb 42
Add Cells to the Watch WINdOW ... 42
Evaluate FOrMUIAS .......cciiiiiiiii e 44
Evaluate @ FOrmuUI ......ccooiiiiiii 44
Advanced FOrmatting.....cccevceereeeeiieiiisssnnneeneneessnnsssesssssnnsssssessssssns B e nenecssens ....45
Customize Conditional FOrMAtEING.....cccveviriererieie ettt st sae e esaeeseestessereeneesbeensenne 46
Create a Custom Conditional FOrmatting RUIE.......c..ccvirieieriinieieesestereete et 46
Conditional FOrmatting With FOrMUIGS......cc.ieieriiieriieiereseet ettt st sbe e b abesne e 47
Use Formulas with Conditional FOrMatting.........ceeeeviiririeniriierie sttt st se et sne e 47
Manage ConditioNal FOrMAtiNG ....c..coveririiriiiieieice ettt ettt be s e b se st e besaeesenas 48
Edit a Conditional FOrmatting RUIE ..........oouiiieiiiiiieiirineeeseseee ettt s st sas e sae s 48
Change the Order of Conditional FOrmatting RUIES .........ccevieiiirierieniieieereeee et 50
International CUrreNCY aNd FOMMATS ....ccviririierierieie sttt st e st te e se e s entesseentesaeenaesseensesensesseenees 51

iv [Your Company Name]



Change the Windows Regional FOrmMat SEtINGS.......ccverirrieririeriisineeee e eeesie st s seere e steseeneesneenes 51

Apply an International CUITENCY FOTMAT .....ccuieieriiriierieseeiesre ettt se st este s e e tesneesessaensene 53
Display a Date or Time in a Different International FOrmat ........ccoecveverieiiniesieseeeeseseee e 53
21 Yo LV T Yo I o =T 1o 1Y @ o1 o g -SSP P 55
APPIY @ THEME FONT ST c.utiiiiiiiieitie ittt st et sa e sb e s b e e sabesae e s e beeeabeesabesaseesateeanee 55
Create @ CuStomM FONT ST ..ouiiiiiiiiiii e 56
(0o ] o T e o T | £ TSSOSO P PSPPI PRRPPRONE 57
APPIY @ COIOT SCREME ...ttt sttt st b e st e s bt e s bt e s b e e saeab e e e bt e ebeesabe e e e e saneenane 57
Create @ CUSTOM COlOr SCNEIME .....co.viiiiiiiieeiee et sttt 58
CUSTOM TREIMES ..ttt ettt ettt ettt b s b et st e e b e s e e e e st e b e e b e e e e et eh s e e e bt ebe s e e e e e eneeb et et enensennens 59
APPIY THEME EIBMENTS ..ottt sttt s et se e e e ae st enaesbeesesseesaet e sesseensesseensensannnenne 59
Create @ CUSTOM TREME....c.iiiieiietetetet ettt ettt b ettt b e st e b s e e b s b b e esesse s e neneene 60
FOPM CONEIOIS .o s h e bt se bt s e b sae e b e sbe et e ebeeneneneeenneneas 61
TUIN ON the DEVEIOPET TAD ...ueiiiiiiiie ettt ettt et eab e e steesbe e st e sbeesabeesanesseenes 61
INSEIt @ FOIM CONTIOL...cuiiiiiiiriteteet ettt sttt e sb e e sne e sae e e ees 63
SAVE FOIM TEMPIATES .. eeiutiieitieitieetee sttt sttt st e bt e e esab e e bt e s abeesabesabbte e b e e eabeebeesabeesanesnnerean 65

Save a Form as a Template .

OPEN 3 FOIM TEMPIATE ..eeiiiieiiieieete ettt ettt b et e et e e te e et e e s bt e e b e e sa b e e besteessbeenbeeenteebaeearean 66
Advanced FOrmMuIlas .......ccccvveiiiineenninnneniinsnneeissssneesssnseesensnn .67
TF FUNCRION ..ttt a e bbb s b e s saeere e 68
INSErt an IF FUNCHION (..ot e 68
NESTEA FUNCHIONS ...ttt sttt b e e sn e 69
INSErt @ NESTEA FUNCHION ...ttt ettt ettt et be ettt et e b et e b e nseeaeenees 69
AND, OR, @Nd NOT FUNCHIONS ...c.uviiiieiieeitee it estee st eseeseteesiaeesseesaseesseeebassessseesaseessseeseassseessessessseesnseessseenseesss 70
Insert an AND, OR, OF NOT FUNCEION ...tiiiiiiiiciiiriieee e eeeeie e eeeeetatreeeeeeeeee e taaaeeesnssseseeeeeseeesnssasseeessnsneees 70
SUMIF, AVERAGEIF, and COUNTIF FUNCLIONS ...cveuviiiiriieieiiciiritieee ettt 71
Create @ SUMIF FOIMUIA ..ottt s er et ne 71
VEOOKUP ...ttt ettt ettt eb e et b e bt ekt b et b e e b et at e b e b e et e st bas et e bt srenee e eneenes 73

Insert a VLOOKUP Function ... 73
HLOOKUP .cevviiiiiiiiiiiiiees 76
Insert an HLOOKUP FUNCEION ..ottt sr st 76
INDEX @NA IMATCH ..ottt st a e st st e e sa e sa e s e nene 79
The INDEX FUNCLION ...t aae 79
ThE MATCH FUNCHION ..ottt ettt ettt ea et b b e sensennennene 81
Combine the INDEX and MATCH FUNCIONS .......ccuciiiiiiiiiiiiiiicici e 82
UPPER, LOWER, @Nd PROPER .....c.cctiiiitiieieeeittese sttt sttt ettt ne et sae e enes 84
UPPER FUNCLIONS ...ttt s e b s b e b sae e ebe e eaae s 84

© 2025 CustomGuide, Inc. v



LOWER FUNCEION ..ttt ettt e st e st e st e s s e e e e s nee e e smneeesanneeeseeesanne 85

PROPER FUNCEION c.eeiiticticiictect ettt s b a e s be e n e bsbeenn s 86
RIGHT, LEFT, @N0 MID ..ottt 87
The LEFT FUNCHION.....cuiiiiiiicicccc bbb 87
The RIGHT FUNCHION ..ottt 88
The MID FUNCHION c.cuiiiiiiiiciic bbb st 89
FOrmula CalCUulation OPtiONS .....ceeuieeiuieeieeiieeiie ettt ettt ettt bt et e bt e be e s b e sabessaeeseebeeenbeesaae e saesanes 90
Change the Formula Calculation OPtioNS........c.eeviiiiiierieeite ettt saeesae e ees 90
LY ] L7 =l 0 T - S o T . SR 91
GO SEEK .t e 92
USE GOl SEEK ...ttt et 92
SCENAMIO IMIANAEGET ..ttt ettt sttt ettt b b bt st e sbe e s bt e e bt e e bt e e b bt e b b e e a bbbt et e e eab s e bb e e bt e e bbe e b e eneebeeea 94
USE SCENAIIO IMIANAGET ...ttt ettt sttt e b e bt e sase s beb b e e bt e sbbesbbesabeesanesnne 94
VIEW @ SCENATO SUMIMAIY ...eiiiiiiiiiieiieete ettt ettt ettt et e st e eae e et eh b e e bt e e b bt e b bt e saeeebeessbeebeeas 96
CONSONIAALE DALA ...ttt st 97
CONSOIIAALE DALA ...ttt e 97
L1 T LN ... 101
EN@DIE MACIOS ...t s 102
Enable Macros in @ SINGIE FIle .....ouiieiiiiieeiieeieee ettt ettt et s ae e steesateens 102
Set Trusted LOCATIONS ....c.ccuiiiiiiiiiiiic e 103

LAY Yol fo Y o = PP P PPPP PP OR PP 106

L0 T LN 1= T oL S 107
RECOIA @ IMTACIO .ottt bbb bbb 107
RUN @ VIO it s sa e b 109

1Y oY 14V Y/ =Tl o T OO O TSRO PRRRT RPN 110
Unhide the Personal Workbook ...........cccoiiiiiiiiiiiiiiiii e 110
EdIt @ IMIACIO .. 111
Test an Edited IMACrO......coiiiiiiiic 112
[OfeT o ALY = Yol o L O PO U ST PO TUPPOPPPPION 113
Copy Macros from ANother WOrkbOOK .........cocueiiiiiiiiiiiieiecese et 113
TESt @ COPIBA IMIACIOc.uvtieuiieeitieite et e st se et e st e et e et e et ae e beesabte e esbeessteenbaeesbeesbeenbeeseassaeenseessseansaeentaenssenn 114

vi [Your Company Name]



PivotTables

PivotTables are one of the most powerful features in
Excel, and they’re surprisingly quick to build, too. With
properly organized source data, you can create a
PivotTable to summarize and analyze data ranges in
just a couple of minutes. There are endless possibilities
for structuring your data in a PivotTable, so you'll want
to have a good idea of what you want to measure or
understand before you start.

PivotTables are good for grouping or expanding levels
of data, transforming columns into rows and vice versa
(“pivoting” data), and filtering and sorting data. They
lend themselves particularly well to forming a concise
summary from long lists of data. They can be used to
build dynamic reports in a fraction of the time it would
take to do so manually, helping you make informed
decisions.

This module explains how to create PivotTables,
modify their structure and formatting, use timelines,
and group values. Once you’ve mastered PivotTables,
you’ll discover there are a variety of ways you can use
them to add value to your projects.

Objectives

Create PivotTables

Add Multiple PivotTable Fields
Change a PivotTable’s Calculation
Add Calculated Fields

The GETPIVOTDATA Function
Filter PivotTables

Timelines

PivotTable Layout

Group Values

Refresh a PivotTable

Format a PivotTable
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Create PivotTabIes\

When faced with a worksheet packed full of data, with many columns and perhaps hundreds or thousands
of rows, making sense of it all can be a daunting task. PivotTables help you pull out just the data you need to
quickly make informed decisions. They are very flexible, easy to adjust, and can be created and modified
with just a few clicks. Don’t worry if PivotTables are confusing at first, they will make a lot more sense once

you start working with them.

Before you start creating one, it’s important to keep a few basic rules in mind:

e Your data should be neatly organized into rows and columns without any blank rows or columns.

e Each column should have the same data type. For example, you shouldn’t have a column of prices
where some cells have the currency format applied and some have the accounting format applied.

e PivotTables can be created using a cell range or an existing table.

]Create a PivotTable

Select any cell in the data
range you want to analyze.

Click the Insert tab on the
ribbon.

Click the PivotTable button in
the Tables group.

The Create PivotTable dialog
box opens. Here, choose which
data to analyze and where to
place the PivotTable.

If you’ve already clicked within
a data range, the Table/Range
field is populated. Verify the
correct range is displayed.

Tip: The data range doesn’t
have to be in the current
workbook. Select Use an
external data source to select
data outside the workbook.

Click C

@

An empty PivotTable and task pane
appear on a separate worksheet. Next
you need to specify the fields you want
to appear in your PivotTable.

File Home  Insert page Layout  Formulas ~ Data  Review  View Help O Tellme 5§
-
= = fe o - [E- - 7=
B F| o 2 P LN e il (db =
PivotTable Recommended Table | llustrations | Add- | Recommended o . Maps PivotChart | 30 | Sparklines »
PivotTables ° ins~ Chans - - - - Map~ s
Tables Chart 5l Tours -
Create PivotTable ? X
A2 b "
Choose the data that you want to analyze
Ll B | @selecatableorrange H © =
1 Date Name Table/Range: | SalestSASHiS5590 +||Total  Commission
2 Jan leohn Har{ Ut sn extermal data source 1,095 Yes
3 Jan 3 Tony Che Choose Connection.. 398 No
4 an 3 Tim Par Connection name: 1,396 No
5 Wan 3 Antonio Use this workbook's Data Model 1197 Yes
I3 Jan4 MQTV W Choose where you want the PivotTable report to be placed 298 Yes
7 Jan5 Amy Wu Qe 374 Yes
O Brsting Worksheet
8 Jan 8 LeAnne P 3 1,770 Yes
9 Jan 8 Maria W N | 2,065 No
J 9 stan Billi Choose whether you want to analyze multiple tables 1180 Yes
e ; 3”10 oo BT Dlaastns st to ne ot ous e =
n an ohn Smi o
12 Jan 10 LeAnne 698 No
3 Jan 11 Maria Rodrigt Washington, 399. 3 1,197 Yes
14 Jan 14 Alice Lindgrar Chicago 199 % 2 398 Yes -
Sales ® < >
Ready i1 m - 1 + 100%
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Commented [IG1]:
Practice File: 01-create-pivottables.xlsx

Commented [IG2]:
1. Select cell A2.

2. Click the Insert tab.
3. Click the PivotTable button in the Tables group.

4. Click OK.




Add PivotTable Fields

Once you’ve created your PivotTable, you have to specify the data you want to analyze. The PivotTable
Fields pane appears at the right. Under the Search field you see a list of all the possible fields you can use in
your PivotTable. These fields are the column headings from the original data source.

To make it a little easier to understand, let’s break it down. Say your original data set contains information
for ticket sales and includes dates, destinations, prices, the number of sales, sales totals, sales agents, etc.,
but all you really need to know is how many tickets were sold each month for each destination. You can grab
the Destination field and the Date field, add them as rows and columns in the PivotTable, and add a numeric
sales field to the values area. The PivotTable will display a subset of the original data, but only include the
values you really need to see.

Click and drag a field to the
Rows area.

Click and drag a field to the
Values area.

If desired, click and drag a field
to the Columns area.

Tip: If you want to filter the
PivotTable, add an additional
field to the Filters area.

The PivotTable updates to display the
values for the fields you’ve added. The
great thing about PivotTables is they
are extremely flexible. If the table isn’t
displaying the data like you want, just
click and drag fields in and out of the
Rows, Values, and Columns areas until
the PivotTable represents the data
correctly.

B 9- s O1-create-pivottables -Excel PivotTable Tools  [H1 - [m]
File  Home | Insert | Draw | Page Layout Formulas |Data Review View Help —Analyze Design O Tell me =
B B 5| | [P nsert siicer I:h [h: [} I T 5]
ES Insert Timeline <
PivotTable | Active | Group Refresh ChangeData | Actions | Calculations | Tools | Show
- Field~ - E *  Sourcer ° < - -
Filter Data S
A3 b £ || Sum of Tickets v
A B c D E F
1 PivotTable Fields v 4
2
Choose fields to add to report:
3 [sum of Tickets _|column Labels - aet b @
g i earch Je
5 Rowlabels [~|2-Jan 3-Jan 4-Jan 5-Jan 8-Jan 9-
6 |Boston 3 Date =
7 |Cancun o O Name
2 |Chicago 2 Destination
9 |pallas 2
10 |puluth 2 Drag fields Betyveen areas below:
11 Los Angeles 13
e Filters Columns
12 |New York 4
13 |Philadelphia Monthe >
14|Toronto Rows: % Values
15 Washington, D.C. 3 Destination E Sum of Tickets v =
16 Grand Total 3 9 2 2 13
> Sheetl | sale .. @ < - Defer Layout Update
Ready B @ o - 1 + 100%

Commented [IG3]:
1. Click the Destination field and drag it to the Rows area.

2. Click the Tickets field and drag it to the Values area.
3. Click the Date field to the Columns area.

Show students how easy it is to change the data in a
PivotTable. Drag all of the fields out of the Columns and

Rows areas. Drag the Destination field in the Columns
area and the Name field into the Rows area.

© 2025 CustomGuide, Inc. 9




Add Multiple PivotTable Fields\

Commented [IG4]:
Practice File: 02-add-multiple-pivottable-fields.xIsx

When adding fields to the Filters, Columns, Rows, and Values areas of a PivotTable, you aren’t limited to just

adding one field; you can add as many as you like. However, if you make it too complex, the PivotTable will
start to become difficult to consume. You may need to experiment with adding multiple fields to certain
areas to see what works best for your set of data. Remember, you can always drag fields out of the area
you’ve added them to in the PivotTable Fields pane to remove them.

Let’s refer back to our previous example, where we are only interested in seeing the monthly sales for each
destination. After creating the PivotTable, your boss may request to see data for which agents made those
sales. Instead of creating a separate PivotTable, you can easily add the Name field as an additional row to

expand the data that’s represented.

]Add an Additional Row or Column Field

Click any cell in the PivotTable.

The PivotTable Fields pane
appears.

Tip: You can also turn on the

File  Home | Insert Draw  Page Layout Formulas Data | Review

L A
oo 1B
Y]

Clippoard = Font

02-add-multiple-pivetiable-

General -
$-%9
o o
@ 50

Algnment | Number

PivotTable Tools

v Help | Analze Design 0 Tellme &

[Ef| Conditional Formatting = = o

T F t as Tabl
i Format o< Table Cells | Editing

Al

fe | sum of Amount

PivotTable Fields pane by
clicking the Field List button on
the Analyze tab.

Click and drag a field to the
or area.

The PivotTable is updated to include
the additional values. The order you
place the fields in each area in the
Fields pane affects the look of the
PivotTable. You can drag the field
values up or down within an area (the
Rows area, for example) to adjust which
data appears first.

Note: Some fields, when added to a
PivotTable, will automatically be
displayed as two fields. For example,
when adding a date field to the
Columns area, Excel will likely group the
dates into months automatically instead
of displaying each individual date as a
column heading. In the Columns area of
the PivotTable Fields pane, you'll see
two fields—Date and Months—even
though you only added a single field.

A B c D E F

1 |Sum of Amount _|Date|~

2 |Destinaf on - Jan Feb Mar Grand Total
3 |Bostor! 2920 365 1825 5110
4 |Cancun 1194 995 1758 3047
5 |Chicago 1194 1582 1791 4577
6 Dallas 748 748 1870 3366
7 |Duluth 1490 1490 894 3874
8 |Los Angeles 7670 1180 2360 11210
9 |New York 4188 2443 6631 13262
10 | Philadelphia 1596 1596 399 3501
11 |Toronto 4886 4886
12 Washington, D.C 3591 4389 399 8379

13 Grand Total
“

29477 14798 17927

Commented [IG5]:
1. Click cell Al to activate the PivotTable and open the
PivotTable Fields pane.

2. Click the Name field and drag it to the Rows area,
below Destination.

The PivotTable now shows who made sales for each
destination each month. If you wish, show students that the
order the fields are arranged in the Rows area matters. In
the Rows area, drag the Name field above the Destination
field to see the PivotTable update. Then drag the Name field
below Destination once again.

PivotTable | Sales

@

@

B Cell Styles -
styles “
PivotTable Fields ~
Choose fields to add to report: &~
Secarch el
O Name =
. Destination
[ Tickets -
Drag filgs between areas below:
Filters Columns
Months -
Rows " Values
| | [ Destination Sum of Amou.. ~
iii m - L + 100%
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\Expand or Collapse a Heading

Once you’ve added more than one value to an area, expand and collapse buttons appear for the top-level
values in the PivotTable. Use these to change how much of the data is visible at once.

Click the Expand or Collapse
symbol next to a row or
column heading.

lAdd an Additional Value Field

02-add-multiple-pivottable-fie...

PivotTable Tools [ -

File  Home Insert Draw Page layout Formulas |Data Review |View Help Analyze Design O Tellme
rﬁD X b General - | | [ Conditional Formatting ~ | | 0
e @~ | $+% 9 | EEFomatasTable- Cells | Editing
B 4 e 8 8 [ Cell Styles - - -
Clipboard = Alignment T Number ) Styles
Al bt Jfe || Sum of Amount
A B ® D E F o
1 [sum of Amount _Date PivotTable Fields = X
2 |Destination |~ |Jan Feb Mar Grand Total Choose fields 19%86d to report
3 |=Boston 2920 365 1825 5110
4 Anna Torkleson 1095 1095 Search
5 Harrison Thompson 730 730
6 John Harris 1095 1095
7 John Smith 365 365 [ Tickets
8 Louis Landgo 730 730 B I Frhecen o brim
9 Phillp Grahams 365 385
10 Shelia Lindqui 730 730 i oy
11, =Cancun 1194 995 1758 3947 Mo
12 Amy Thomas 365 365
13 Bruce Thorgood 796 796 Rows T Values
14 LeAnne Nortor 1194 1194 v Destination ¥ | || Sum of A
PivotTable | Sales | @ [ v Mame. -
B ] B - 1

s

mou...

+ 100%

If your original set of data has multiple columns with numeric values, you may find yourself adding
additional fields to the Values area. If this is the case, the PivotTable will display the sum of one set of data
followed by the sum of the second set of data in an adjacent column.

Click and drag a second field to

02-add-multiple-pivottablesfie...

PivotTable Tools.

Commented [I1G6]:
1. Click the Collapse button next to Boston.

Point out that both the Rows and Columns in the PivotTable
have buttons to collapse and expand the data.

Commented [IG7]:
1. Click and drag the Tickets field to the Values area,
below the existing fields.

The PivotTable now shows the number of tickets sold and
the total amount for each destination and each agent.

the Values area File  Home | insert | Draw | Page Layout | Formulas | Data | Review |View Help = Analyze Design 0 Tell me G
fﬂ X Calibri <l - 25, General - | [E Conditional Formatting = 0
) . . DEE @™-|BIU- A& - $-9% 9 | [FHFomatasTable s | EEms
The order in which you place the fields T & o A- P BB Cel syles~ S
In the Values area |S Very Important. If Clipboard = Font ] Alignment T Number T Styles ~
you add a field and the PivotTable » X sty H
. . o A B c D E F -]
doesn’t look right, try adjusting the B ST r———— | PivotTable Fields ~ X
order of the fields until the PivotTable |2 Destinaton - Jan Feb Mar Grand Total Choossfieldsto sddtoreport:. | & -
. 3 |+ Boston 2920 365 1825 5110
displays useful data. 4 = Cancun 1194 995 1758 3947 Search el
5 Amy Thomas 365 365 o
[ Bruce Thorgood 796 796
7 LeAnne Nortor 1194 1194 W [ Tickets -
& Roger Bilco 199 199 Drag fiels between areas belows
9 Ruth Therman 199 199
10 Terry Nordstrom 308 208 (o= Celrme
1" Tony Chekov 796 796 [Maaths| e
12 = Chicago 1194 1592 1791 4577
13 Aaron Burr 597 597 Rows. X Values
14 Alice Lindgran 398 398 - Destination  ~ Sum of Amou... ¥
PivotTable | Sales | @ « v Name -
B ] m - ' - 0%
© 2025 CustomGuide, Inc. 11



]Change a PivotTable’s Calculation

Besides adjusting the layout of your PivotTable data, you can also change how a PivotTable summarizes
values. For example, you might want a PivotTable to display averages instead of totals.

Change PivotTable Calculations

0 Click any cell inside the 5.change-pivotables-calul —
PivotTabIe. File  Home Insert Draw Pagelayout Formulas Data Review View Help Analyze Design 0O Tell me
] B | | B nsertslicer [5’ [\i 7] dh [ g
e Click the Analyze tab on the P > Active | Group ?‘“E"T‘me‘i”e Ref,:;‘ Changm Actions | Calc v s8ns | Tools | Show
. Fild- - i ~ Sourcer & 3 - .
ribbon. - -
Active Field: .
e Click the Active Field button on  [**— sumesamoun B
. [ Field Settings - Eo B
the ribbon. , [sumc< BRiedseteng " PivotTable Fields i
s .
. . . 2 @Jan  @Feb EMar Grand Tot| | cpoose fields to add to report:
Click Field Settings. 2 | Dination -
o 4 |BoSton 1460 365 730 25 | [seoren
The Value Field Settings dialog |5 Cancun 199 398 962 1 Date
6 |Chicago 597 796 597 1 [ Name
box appears. From here, you 7 Dallas 374 374 1309 2 Destination
can select calculation options 8 |Dulth 536 G5, %6 1 R e
. . 3 Los Angeles 1475 590 885 29
including Sum, Count, Average, |1 new York 1047 1396 3839 62 Y Filters W Columns
or Max among others 11 |Philadelphia 399 1197 399 19 Months.
4 : 12 \Toronto 1396 13 = s = e
., -+ P 13|Washington, D.C. 1197 1197 399 2 Destination ~ = [ sum of Amount
Tip: When a field containing 12| Grand Total 8740 6611 9716 250 .
numeric values is added to a o [rwomame | @ L ; P tee
Ready =] |- 1 +

PivotTable, Excel automatically

=)

Commented [IG8]:
Practice File: 03-change-a-pivottables-calculation.xIsx

Commented [IG9]:
1. Click cell A1.

2. Click the Analyze tab.

3. Click the Active Field button to expand the ribbon
group, if necessary.

4. Click Field Settings.
5. Select Average.

6. Click OK.

calculates the sum.

o Select the type of calculation PHotiabe ool
you want to use Fle  Home Insert | Draw | Page Layout | Formulas | Data Review  View Help  Analyze Design O Tell me 55
&} = 5| | [P nsert slicer [5’ [h i ) B
: -
Click OK. D - | P meiTmeine Refen Change Data | Actions | Calculations | Tools | Show
- Fd- | - | © Sourcer v © = =
i . . Value Field Settings 70X
The summarized data in the PivotTable |, = comcetame. Amount
changes to use the new calculation. A i [Cu=tom Namegfiersse T Amaird
1 [Sum of Amount lDate Summarize Values By Show Values As Ids M
2 #Jan  summarize value field by report (O
3 Destination = Chease the type of calculation that you want to use to summarize
« Boston 14| gete trom the selected ieid ol
5 |Cancun 14 |Zount - =
6 Chicago Max
7 |Dallas 3] [oe < 2
8 |Duluth 5
3 Los Angeles 14 e belowe
10 | New York 104 | MumberFormat el Elre
11 |Philadelphia 399 1197 399 1 Months. v
12 | Toronto 1396 1 £F Rows I Values
13 |Washington, D.C. 1197 1197 399 2 Destination ~ = sum of Amount _~ |F=
14 | Grand Total 8740 6611 9716 250 .
» PivotTable | .. (&) ] v el
Ready i om - ' - 1o%
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Ll-\dd Calculated Fields\

Commented [IG10]:
Practice File: 04-add-calculated-fields.xIsx

A calculated field is a new field that performs calculations based on existing fields in your PivotTable. For

example, you could use a calculated field to find the average ticket sales using an existing total sales field
and a field containing the number of tickets sold.

‘Create a Calculated Field

Click a cell in the PivotTable.
Click the Analyze tab.

Expand the Calculations group,
if necessary.

Click the Fields, Items, & Sets
button.

Select Calculated Field.

The Insert Calculated Field
dialog box displays. This is
where you’ll create and name
the field.

Type a name for the calculated
field in the Name field.

Click in the Formula field.

00 0

Enter a calculation using the
fields in the list and/or custom

04-add-calculated-fields - Excel

PotTable Tools

Tools

O Tell me
&

Show

1l Columns

= Values

Sum of Amount

File  Home | Insert Draw  Page layout | Formulas Data | Review View Help —Analyze
=} B | | EPinsertslicer [5: [h: B [ ¥
B Insert Timeline: i
PivotTable | Active | Group Refresh Change Data »  Calculations
- Fid- |- | B - Sourcer ° o
Filter Data
Ee =
B1 o Fe || sumof Amount 0l [ o
W Fields, ltems,
) B © 2 S gsers
1 |Destination  -[Sum of Amount | Pivot
- Caleulated Field
2 |Boston 2,555 Choose fie
3 Cancun 1,559 ot
4 |Chicago 71,990 Search o =olve Dz
7 ListFormulas
5 |Dallas 2,057 LI Name
6 | Duluth 1,490 estin
7 |Los Angeles 2,950 [ Amour
& New York 6,282
. . Drag fields beiig Below:
s Philadelphia 1995 rag fields between areas Below:
10 Toronto 1,396 T Filters
11 |Washington, D.C. 2,793
12 | Grand Total 25,067 = Rows
13 Destination - =
14
» PivotTable | .. (& < y CEle Ut
Ready i m -

[

Commented [IG11]:
1. Click cell B1.

2. Click the Analyze tab.

3. Expand the Calculations group, if necessary.

4. Click the Fields, Items, & Sets button.

5. Select Calculated Field.

6. Type “Average Sales” in the Name field.

7. Click the Formula field.

8. Delete the 0. Click Amount in the Fields list and click
the Insert Field button. Press the / key and double-click

Tickets in the Fields list.

9. Click OK.

Piotfable Tools

Point out that Excel automatically labels the row heading
“Sum of Average Sales”. If you want, show students how to
modify the row heading using the formula bar.

values. File  Home | Insert Draw | Page Layout | Formulas 'Data | Review View Help =Analyze Design 0O Tel me @
5 B B | | EInsertSlicer [5: B [ [ B
TIP: You can also enter your PivotTable | Active | Group Ieleat T et Change Data | Actions | Calculations | Tools | Show
own values in the formula. For N G I _— . : I
3 Insert Calculated Field 7 x =
example, you could find a = s .
. Name: | Average Sales o Add
monthly average by adding an DV = -l §
existing field and then dividing | ! |Pestination [~
2 |Boston Fields: &~
by 12. 2 |Cancun
4 | Chicago el
o Click OK. 5 |Dallas .
6 |Duluth
7 |Los Angeles A
The new calculated field is & New York Insert Filg _
ically added he PivotTabl s | Philadelphia = e N
automatically added to the PivotTable. |, oronto S
11 |Washington, D.C. 2,793
12| Grand Total 25,067 = ,.(;' = Values
13 Destination ~ = [ sum of Amount  ~ |=
14
» PivotTable | .. @ < > IEEloEnilri
Ready ] m - 1 100%
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]Remove a Calculated Field\ Commented [1G12]:
1. Uncheck Average Sales in the PivotTable Fields pane.

If you decide you don't need the calculated field in your PivotTable, it can be removed just like any other
PivotTable field.

o Uncheck the calculated field in B9 O4-acldcalulated-ields - Excel owotiableToos [ — O
the PivotTable Fields pane. File ~ Home Insert Draw  Pagelayout Formulas Data Review View Help Analyze Design O Tellme (=]
= M= 57 Insert Slicer = = =
E ’n__&] & g\nse:ﬂmelme D/_j @ ﬂ £ E
. . PivotTable | Active | Groy resh Change Data | Actions | Caleulations | Tools | Show
The calculated field is removed from | e | OV | P ERin | 52 - ok | e
the PivotTable; however, it remains in iter pete -
the field list to use again in the future. = . L] ol =
B C D -
1 |Sum of Amount |Sum of Average Sales _| PivotTable Fields N @
Note: If you want to remove the 2 2,555 183 Gy & -
. 3 1,559 82
calculated field completely, you need . 1,990 87 Search ps)
to re-open the Insert Calculated Field 5 2,057 114 [ Average Sales -
. . 6 1,490 57
dialog box, select the field you created , 2,950 78 Drag felds between arcas below:
in the Fields list, and click the Delete g 6,282 165 Fiters Columns
s 1,995 222 el =
button. 10 1,39 100
Ll 2,793 133 Rows ¥ Values
12 25,067 114 Destination + | [sumofAmount  + |
13 Sum of Average Sal. ¥ |7
14 _
5 M‘b B o Defer Layout Update
Ready i) m - M + 100%
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The GETPIVOTDATA Function

Commented [IG13]:
Practice File: 05-the-getpivotdata-function.xlsx

The GETPIVOTDATA function is used to extract data from your PivotTable. You place the function in a cell
outside of the PivotTable, and it uses data within the table to perform a calculation. The syntax for the
GETPIVOTDATA function looks like this: =GETPIVOTDATA (data_field, pivot_table, [field1, item1], ...). You fill
in the function with the following information:

e data_field: The name of the field in the PivotTable you want to query.

e pivot_table: Any cell located in the PivotTable.

o fieldl, item1 (Optional): The field or item you wish to reference.

Use the GETPIVOTDATA Function

o Click in a cell outside the = a8 the-getpivotdata-function - Excel Kayla Claypaol
PivotTable Where yOU want to File Home  Insert  Draw  Page layout  Formulas  Data  Review View Help O Tellme [
add the function. S ZIRRRS
B- Cells | Editing
€) Typethe = sign. Al
e Click the cell in the PivotTable macn - L X~ & IS
. A B C D E F G 4
that contains the data you S T = T
want to extract. 2| Average Daily Sales| =| |
3 |Destination - Sum of Amount
— B 4 Boston 1,460
As. sz?on as ypu type =and click |2 >0 5
within the PivotTable, the & |Chicago 597
. . 7 |Dallas 374
GETPIVOTDATA function is A buluth coe
automatically added. 3 Los Angeles 1,475
10 |New York 1,047
o (Optional) Expand the function |11 Philadelphia 399
. . 12 \Toronto 1,396
to include additional 12 Washington, D.C. 1,197
calculations. gl 8.740 <P -
L pivotTable | saes | @ : :
=E B o - +

The advantage of using the
GETPIVOTDATA function instead of a
cell reference is that it records data to
ensure the correct value is returned,
even if the location of the referenced
cell changes when the datain a
PivotTable is updated.

Tip: If you happen to be using cube
functions as part of your Excel
workbooks, note the GETPIVOTDATA
function has almost all of the
expressions you'll need for your cube
functions. You can paste these
GETPIVOTDATA values into your cube
functions to save time and simplify the
process.

© 2025 CustomGuide, Inc. 15

Commented [IG14]:
1. Select cell E2.

2. Type the = sign.
3. Click cell B14.
4. Press the / key and then type 22. Click or press Enter.

5. Click the Filter list arrow in cell B2 and select March.
Click OK.

Point out to students that the formula in cell E2 updates to
show the new average daily sales for March, even though
the referenced value moved from cell B14 to B13.



https://na57.salesforce.com/a083300000h9dKZ

Filter PivotTabIes\

Commented [IG15]:
Practice File: 06-filter-pivottables.xlsx

Much like you can with basic data ranges and tables in Excel, you can filter a PivotTable to focus in on a

smaller portion of data.

For example, instead of showing the sales values for every destination, you can add the Commission field as
a report filter to show only the sales for which an agent earned a commission.

’Add a Filter Field\
0 Click any cell in the PivotTable.

o Drag a field to the Filters area
in the PivotTable Fields pane.

The filter field appears at the
top of the PivotTable. The text
(All) is displayed so you know
the data is not currently being
filtered.

0 Click the list arrow for the field
you’ve added as a filter.

A list of sorting and filtering
options appears. The items
available in the menu will differ
based on the field you’'ve
added as a filter. Additionally,

a Search field appears at the
top of the filter list. If desired,
manually type the criteria by
which you want to filter.

Tip: You can also filter the row
or column headings in a
PivotTable by clicking the Row
Labels or Column Labels list
arrow and selecting only the
value(s) you want to display.

o Select the item(s) you want to
use as a filter.

e Click OK.
The PivotTable updates to display only
the values that meet the filter criteria.

File

i)

Paste

AL

X Calibri MITE
-| BT U- A&A

<3 [ 3 A -
Clipboard & Font il
T i3

A B

General  ~

|Sum of Amount lDate -

“Jan

Destin ] v

Boston 1,460
Cancun 199
Chicago 597
Dallas 374
Duluth 596
Los Angeles 1,475
New York 1,047
Philadelphia 399
Toronto 1,396

Washington, D.C. 1,197

| 14 Grand Total 8,740

’ PivotTable

Reacy

1 8-% 09
- 34
Alignment Ll Number
Sum of Amount
c D
“Feb “Mar Grand T
365 730 2)
398 962 1
796 597
374 1,309 -
298 596 1
590 885 2
1,396 3,839 6
1,197 399 1,
1
1,197 399 2
6,611 9,716 25,
< »

[}

PivotTable Tools  [F

Home Insert Draw | Page Layout Formulas Data Review View Help Analyze Design

[EH Conditional Formatting -
[ Format as Table -
[ Cell styles ~

Styles

PivotTable Fields
Choose fields to add to report:
Search

[ Total

b [ Commission

Months

Drag fields between areas below:

Filters

Months

Rows 3 Values

Destination <=
Defer Layout Update

B = M| -

Sum of Amount

+ 100%

Commented [IG16]:
1. Click cell A1.

2. Click the Commission field and drag it to the Filters
area.

3. Click the filter list arrow in cell B1.
4. Select Yes.
5. Click OK.

The PivotTable updates to show only the sales where an
agent earned a commission.

File

06-filter-pivottables - Excel

PivotTable Tools

Home Insert Draw | Page Layout Formulas Data Review View Help —Analyze Design

[BH Conditional Formatting -
[ Format as Table~
[ Cell styles ~

Styles

PivotTable Fields

| | choose fields to ad to report:

Reacy

Lﬁi X Calibri -4 - % General
o B | BT U~ A A 1 8-% 09
- €olhye 38
Clipboard & Font. ) Alignment Ll Number
AL o Commission
A B / c D E [«

1 |Commission l(an) - \
2 | i Search
2 Sumof Amount Date (a1
4 #Jan No
5 |Destination - e,
6 |Boston 1,4¢
7 Cancun 19
& |Chicago 5¢
o Dallas 37
10| Duluth 5¢
11| Los Angeles 1,47 [ Select Muttiple ltems
12 | New York 1,04 Cancel
13 |Philadelphia 3¢
18| Toronto 1,396 1~

» PivotTable | .. (& 1 >

Search

[ Total
Commission
Months

Drag fields between areas below:

Filters

Commission -

Rows 3 Values

Destination - =
Defer Layout Update

B = M -

Months

Sum of Amount

]
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\Clear a Filter Commented [IG17]:
1. Click the filter icon in cell B1.

Once you’re done analyzing the filtered data, clear the filter to see all the data in your PivotTable again.

2. Select All.
a Click the filter icon next to the 06-fiter-pivottables - Excel Pvotiable Tools X )
filter f|e|d Fle  Home Insert Draw Page Layout Formulas Data Review View Help Analyze Design 0O Tellme <3 3. Click OK.
Eﬁ X & | |General || EllConditional Formatting~ | | 1y 0
e Select All. pae 7 o | §-% 9 | BFomatasTabie- Cells | Editing
B L2 0 58 [ Cell Styles - - -
e CIICk oK Clipboard 1 Font 5l Aignment | Number & Styles ~
AL i ¢ Commission v
. . A B C D E |~
The filter is cleared from the s [ || PivotTable Fields M
PivotTable, showing all the data once 2 search el e
. 5 |Sum of Amount Date .y 0
again. a ®lan No Search 0
s |Destination |- s 0 Total =
6 Boston 1,0¢ Commission hrd
7 |Cancun Months ~
g Chicago 1<
o Dallas 18 Drag fields between areas below:
10 Duluth 14  Fiters Il Columns
11| Los Angeles 5¢ [ Select Multiple ltems e = Months =
12 |New York 6¢ Cancel = Rows = Values
13 | Philadelphia Destination - = Msum ot Amount + 1=
14 Toronto 1,047 \ 1, -
N PivotTable | .. @ . ’ 5 Defer Layout Update
Ready # o o - 1 + 100
‘Remove a Filter Commented [IG18]:
1. Click the Commiission field in the Filters area and drag it
When a filter is cleared, all the data is visible; however, the filter remains in the PivotTable to use again. If to the sheet area to remove it.

you want the filter gone completely, you'll need to remove it.

o Click and drag the field out of 06-filter-pivottables - Excel PuotTable Tools | B
the Filters area File  Home | Insert Draw | Pagelayout | Formulas Data | Review View |Help = Analyze Design O Tell me &
fﬁ £ Calibri 4 | = ab General  +| | [ElConditional Formatting ~ = 0
Tip: You could also uncheck the | .o @~ B U~ x4 & T $-%3 | BFomats Tebie- Cele | Ean
g
. B . . 7 S~ A - = 158 [ Cell Styles = - -
field in the fields list. B AR PP ey, Sy "
AL e ¥ || commission *®
The filter is removed from the A 5 c o D
PivotTable entirely 1 [Commission (i) [~ PivotTable Fields v
2 Choose fields to add to report: &~
3 Sum of Amount Date -
s #lan +Feb “Mar GrandT = [=rh el
5 |Destination - 0 Total <
6 |Boston 1,460 365 730 2 [4] Commission
7 |Cancun 199 398 962 1 Months ~
& Chicago 597 796 597 1,
s Dallas 374 374 1,309 2 Drag fields between areas below:
10 | Duluth 596 298 59 T Fitters 1l Columns
11 |Los Angeles 1,475 590 885 2, Commission - Months -
12| New York 1,047 1,396 3,839 6, = 3 Values
13 | Philadelphia 399 1,197 399 1 D n v = |[sum of Amount  + |=
14| Toronto 1,396 1,-
» PivotTable | .. & < v Defer Layout Update
Ready i m - 1 + 00%

© 2025 CustomGuide, Inc. 17



h‘imelines\

Timelines are interactive filters that let you quickly filter by date. They make it quick and easy to see
PivotTable data for only the time period you specify. They are similar to slicers in that you can insert them
once and keep them with the PivotTable to update at will.

]Insert a Timeline

Click any cell inside the

PivotTabIe. Fila  Home Insert Draw Pagelayout Formulas Data Review View Help Analyze Design O Tell me &)
=] [} | [ Insert Slicer [5, [\i B [} B
o Click the Analyze tab on the FrvotTble | Actie P etTindie | 0] s | PR | T | 5N
. - Field - & - Source~ o - - -
ribbon. Filter ~
Insert Timelines 7 X
Click the Insert Timeline Al - el B3 i
) P 4 oste . . " -
button. 1 :Sum of Amount _Destinatia
. ) 2 |Name ~ Boston uluth Los Angeles New York Ph
Tip: You can also insert a 3 Aaron B
Timeline for PivotCharts and ¢ Alice Lindgram
i 5 |Amy Thomas 149
cube functions. 6 Amy Wu
7 Anna Torkleson 149 349
The Insert Timelines dialog box | ﬁ"”e ‘?'5:" 349
. 9 |Antonio Rommero [ |||
appears. It automatically 10 Bernice Young 149
detects the date fields used in | BrettHil j1oo 187
. 12 |Brian Samuals 295 349
the PivotTable and has them 13 |Bruce Thorgood 199 187
available for you to select 14/ Gayle Youngauist 349 |-
! X PivotTable | Sales ® <« >
from. Many times, there will Reacy @ o - ' + tors

only be one available field.

Select the date field you want
to use for the timeline.

Click OK.

00 ©

. q Connections | Styles~
Select a time span in the it e e B Show 8
Timeline you want the Date - &
PivotTable to display. A 5 c o e r s H B
1 |Sum of Amount Destination -
T|p To select mu|tip|e 2 Name ~|Boston Cancun Chicago Dallas Duluth Los Angeles New York Ph
. . 3 |Aaron Burr 199
intervals, you can click and + | Alice Lindgram 199
drag along the timeline or click | ﬁg;m‘j’"“ Date T
the first interval you want to 7 AnnaTorkleson s o 349
include and hold the Shift key [ & /AnneClsen Pan  reo w am oy on w T 349
2 Antonio Remmero

while clicking the last interval
in your chosen span.

PivotTable Tools.

Commented [IG19]:
Practice File: 07-timelines.xIsx

Commented [1G20]:
1. Click cell A1.

2. Click the Analyze tab.

3. Click the Insert Timeline button.

4. Click the Date check box.

5. Click OK.

6. Select JAN in the Timeline. The PivotTable updates to
show only the January data. Then, hold down the Shift

key and select June. Once again, the PivotTable updates
to show all the selected months.

Timeline Caption:

Date

File

Home Insert Draw

07-timelines - Excel

= :
@ A T Heighe 157
Quce | Aronge | ez

Kayla Claypos]

Page Layout Formulas Data Review View Help

Header

options O Tellme &

Scrollbar

Selection Label [] Time Level

Bernice Young
Brett Hill

& a

12 |Brian Samuals 295 349

12 |Bruce Thorgood 199 187

14 |Gayle Youngquist 349 -
PivotTable | Sales | @ « >

Reacy 2] m - ¥ + 100%
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\Clear a Timeline

You can clear the Timeline at any point to restore all the data in the PivotTable.

Click the Clear Filter button at
the top-right corner of the
Timeline.

All the PivotTable data is visible once
again.

‘Remove a Timeline

File  Home Insert Draw

Timeline Caption: E@

Report

Date
Connections

Timeline
Date o

A

Page Layout

B

Quick
Styles~

Timeline Styles

£~

B

o

Arran,

Formulas  Data

07-timelines - Excel

Kayla Claypool [

Review View Help  Options 2 Telme &

THeight: 15" Header Scrollbar

ge

width: 365" - Selection Label [ Time Level

size = Show -

@ D E F [ H |

1 Sum of Amount
2 Name

3 |Aaron Burr
4 |Alice Lindgram

5 Amy Thomas

6 [Amy Wu

7 |Anna Torkleson

8 |Anne Olson

9 |Antonio Rommero
10 |Bernice Young

11 |Brett Hill

12 |Brian Samuals

13 |Bruce Thorgood
14 | Gayle Youngquist

Destination -
~ | Boston

Cancun Chicago Dallas Duluth Los Angeles New York PP|

Date

2014
18N

ai-az2014

FEB MAR  APR  MAY  JUN  JUL

MONTHS
349

349

295 349
199 187

PivotTable | Sales |

Ready

@®

g @ o - 3 + 100%

Commented [IG21]:

1. Click the Clear Filter button in the Timeline.

If you no longer need to use the Timeline, it can be removed from the sheet entirely.

Right-click the timeline.

The timeline is removed from your
PivotTable.

Select Remove Timeline.

File  Home Insert Draw

Timeline Caption: E’é‘

Page Layout

B

Formulas Data

07-timelines - Excel Kayla Clagpool

Review View Help Options P Tellme “

@ 1T Height: 1.5 Header Scrollbar
Date CU::Z:‘:‘VM s?y‘;‘;kv Arange | = et 365 2 Selection Label [ Time Level
Timeline Timeline Styles Size ® Show ~

Date b I

A B c o El < H -

T P—— [® Copy

1 |Sum of Amount Destination [~ - -
2 |Name ~|Boston Cancun Chicag L Emommm ngeles New York Ph
3 |Aaron Burr Lo
4 |Alice Lindgram Refresh
s |Amy Thomas
6 |Amy Wu F Report Connecti
7 |Anna Torkleson Remove Timeline o 349
& |Anne Olson . n 349
9 | Antonio Rommero § .
10 |Bernice Young )
11| Brett Hill
12| Brian Samuals Assign Macro 295 349
12| Bruce Thorgood Size and Properties...
14| Gayle Youngquist 349 -

PivotTable | Sales | (B bl v
Ready iz} m - 1 + 100%

Commented [1G22]:
1. Right-click the Timeline.

2. Select Remove Timeline.
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]PivotTabIe Layout\

There are several options for altering the layout of your PivotTable. The Layout group on the Design tab
allows you to change what elements appear on the PivotTable.

]PivotTabIe Layout Options

Click any cell inside the
PivotTable.

The Analyze and Design tabs
appear under PivotTable Tools
on the ribbon.

Click the Design tab on the
ribbon.

The Layout group has options
to change which elements
appear in your PivotTable.

e Subtotals: Click to show or
hide subtotals, and to
specify where to show
them.

e Grand Totals: Click to show
or hide grand totals, and to
specify whether they appear
for rows, columns, or both.

e Report Layout: Show the
PivotTable in compact,
outline, or tabular form.

e Blank Rows: Insert or
remove a blank line
between each grouped item
in the PivotTable.

Click the Layout button for the
element you want to update.

A list of options appears,
depending on the button that
was selected.

Select an option from the list.

The PivotTable layout is updated based
on your selection.

X Calibri
0 @-| B I
<

File  Home Insert Draw Page layout Formulas Data Review  View Help

General  ~

PivotTable Tools

Analyze  Desi

[Ef Conditional Formatting,

gn PO Tellme

=

[

03-pivottable-layout - Excel

File  Home Insert Draw | Page Layout | Formulas Data Review  View | Help

= -

PiotTable Tools

Analyze ign

Desi

O Tellme

Paste ficf&d v $-% 9 | HifomatasTable- W Cels | Editing
- O A B 4 [ Cell Styles - B "
Clipboard 1 Font 5l Algnment  nl Number Styles
AL = J< || sumof Amount
A ] € D E F G H
1 [Sum of Amount |Date -
2| “.Jan “Feb +Mar GrandTotal
3 |Destin, ] -
4 |Boston 1,460 365 730 2,555
5 |Cancun 199 398 962 1,559
6 |Chicago 597 796 597 1,990
7 |Dallas 374 374 1,309 2,057
8 | Duluth 596 298 596 1,490
9 Los Angeles 1,475 590 885 2,950
10 New York 1,047 1,396 3,839 6,282
11 |Philadelphia 399 1,197 399 1,995
12 | Toronto 1,396 1,396
13| Washington, D.C. 1,197 1,197 399 2,793
14 | Grand Total 8,740 6,611 9,716 25,067
PivotTable | Sales | (&) b v
Ready i m - 1 + 1005

=)

Subtotals Grand  Report Blank | PivotTable Style
*  Totalst  Layout Rows~ | Options-
Layout PivotTable Styles
AL Fe | Sum of Amount
A—/ B € D E F G H
1 |Sum of Amount lDate -
2| #Jan +Feb “Mar Grand Total
3 Destination =
4 |Boston 1,460 365 730 2,555
5 |Cancun 199 398 962 1,559
6 |Chicago 597 796 597 1,990
7 |Dallas 374 374 1,309 2,057
8 | Duluth 596 298 596 1,490
9 |Los Angeles 1,475 590 885 2,950
10 New York 1,047 1,396 3,839 6,282
11 |Philadelphia 399 1,197 399 1,995
12 | Toronto 1,396 1,396
13| Washington, D.C. 1,197 1,197 399 2,793
14 |Grand Total 8,740 6,611 9,716 25,067
PivotTable | Sales | &) « >
Ready ] m - 1 + 1005

Commented [1G23]:
Practice File: 08-pivottable-layout.xlsx

Commented [1G24]:
1. Click cell A1.

2. Click the Design tab.

Expand each of the options in the Layout group to show
students what is available.

3. Click the Grand Totals button.

4. Select Off for Rows and Columns.
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\Group Values\

Commented [IG25]:
Practice File: 09-group-values.xlsx

You can group PivotTable data in order to set it apart from additional subsets of data. You can group most
items, but dates are a common item to group. For example, you may want to group the information in the
PivotTable by days, months, quarters, or years.

‘Group PivotTable Values

Click any cell that has a value
you want to group by.

Click the Analyze tab on the
ribbon.

Click the Group Field button.

Tip: You can also right-click a
cell and select Group from the
menu.

The Grouping dialog box
appears.

Specify how you want to group
your PivotTable.

When grouping date values,
the default starting and ending
dates are the first and last
dates in the PivotTable.

Tip: To group dates by weeks,
select Days in the By area of
the Grouping dialog box and
enter 7 in the Number of days
field below the list.

Click OK.

The PivotTable groups together all the
data.

09-group-values - Excel

PotTable Tools

File  Home | Insert Draw  Pagelayout | Formulas Data | Review View Help Analyze Design 0O Tel me
B g | — GroupsSelection [ insert Slicer [h [h. = & [
- ) \ X
g - S}
PotTable | Acive | 20 Ungroup [ et Timeline Refresh Cha 5 | Wagehs | Calculations | Tools
- Field - | [T]Group Fieid 3 + Sourcer v ° N
Group Fiter Data
B3 % K || 2-)an
A [ C D E Fols
1 |SumofTickets  Date - PivotTable Fields
z “Jan Choose fields to add to report:
2 |Destination ~|2-Jan [3-Jan 4-Jan 5-Jan 8-Ja
4 |Boston 3 Bearch
5 |Cancun e
6 | Chicago 2 [ Name
7 |Dallas 2 Destination
& |Duluth 2
o Los Angeles 1 Drag fields between areas below:
10| New York 4 Filters: Columns
11 |Philadelphia Months
12| Toronto Rows = Values
13 Washington, D.C. 3 Destinstion = 151 sum of Tickets
14 |Grand Total 3 9 2 2 1

» PivotTable | .. @ «

Ready

Defer Layout Update

B o m-—38

Commented [1G26]:
1. Click on cell B3.

& 2. Click the Analyze tab.
E]
Show 3. Click the Group Field button.
- 4. Update the By area so only Months is selected.
- % 5. Click OK.
@') -
s
+ To0%

File  Home  Insert Draw  Page Layout  Formulas Data | Review View Help Analyze Design O Tellme
B g | = GroupSelection [ Insert Slicer [\; [b. 72} i} [
. @HUngroup = Insert Timeline. et .
PivotTable | Active | Refresh Change Data | Actions | Calculations | Tools
- Field - | [T]Group Field & - Source- - . °
G
roup Emarr T
B3 5 el 2N pve
A B C arting at: | 1/2/2019
1 |SumofTickets  Date - A Endingat: 33172019 able Fields
2 -Jan By ds to add to report:
3 |Destination ~|2-Jan |3-Jan| |seconds
J Minutes
4 |Boston 3 Hours
D
5 Cancun e
H Quarters
& |Chicago 2| | et
7 |Dallas Jation
s Duluth Number of days: |1 15
s |Los Angeles s between areas below:
8
10 New York 4 1l Columns
11 |Philadelphia Months
12| Toronto = Rows = Values
13 Washington, D.C. 3 Destination = 15| sum of Tickets
14| Grand Total 3 9 2 2 1

Puotfable Tools

» PivotTable | .. @ <

Ready

Defer Layout Update

B @ m-—37=

=
E|

Show
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]Ungroup PivotTable Values Commented [IG27]:
1. Select cell B2.
If you decide you want to see the individual values as column headers again, just ungroup them.

2. Click the Ungroup button on the Analyze tab.

0 Click a cell that contains the 9-group volues - Excel Pvetabl ool
value you want to ungroup. File  Home | Insert Draw  Page Layout Formulas Data Review View Help Anabze Design © Telme 15
i@ = | = GroupSelection | [BF Insert Slicer [% [\i B B 51 g
. z
Click the Ungroup button on pivottatle | T 22 Ungroue o=t Refresh ChangeData | Actions | Calculations | Tools | Show
- Field = Group Field S - Cource~ > = 4 o
the Analyze tab. Az 2
Tip: You can also right-click a e = e =
Il and select U f A o = = pi ‘
cell and select ngroup from 1 |Sum of Tickets  Date - PivotTable Fields R
the menu. 2 | Destination 'Ehb Mar Grand Total Choose fields to add to report: &~
3 Boston 8 1 5 14
4 |Cancun 6 5 8 19 Search A
The grouping is removed from the s |Chicago 6 8 9 23 Date -
. 6 |Dallas 4 4 10 18 [ Name
PivotTable. 7 Duluth 10 10 6 26 Destination -
8 |Los Angeles 26 4 8 38
o INew York 12 7 19 38 Drag fields between areas belowr:
10 | Philadelphia 4 4 1 9 Y Filters | Columns
11 Toronto 14 14 Date =
12 |Washington, D.C. 9 11 1 21 = Rows 2 Values
13 Grand Total 99 54 67 220 Destination < 1= ([ Sum of Tickets - =
14 -
) PivotTable 5 S Defer Layout Update
fexdy & o - 1 + 100
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. Commented [1G28]:
‘REfrESh a P IVOtTa b I e‘ Practice File: 10-refresh-a-pivottable.xIsx. Begin on the Sales

worksheet.
If you make changes to the source data a PivotTable is based on, the PivotTable isn’t automatically updated.
Instead, you must manually refresh the PivotTable anytime you change its underlying source data.
Manually Update a PivotTable Commented [1G29]:
1. Select cell E2 in the Sales worksheet and replace the
0 Make a change to the 10-ciresh-a-pivattable - Bxce Kayla Clayposl value with 30. Press Enter to see cell F2’s value changes
PivotTabIe’s source data. File Home  Insert  Draw  Pagelayout  Formulas  Data  Review View Help 2 Tellme @ to 10,950.
il X Calibri -4 - General - | | [EH Conditional Formatting - =] 0
i i . - u-|a - % | dalaat Cells | Editing . Click the PivotTable worksheet tab.
Navigate to the PivotTable @B 1 U-[AA $ - % 9 | [BfomatsTabl 2. Click the PivotTabl ksheet tab
s O A - B <55 [EA Cell Styles~ - -
H H H Clipboard Font 5l Algnment =l Number Styles ~
e Click any cell inside the J 2 3. Select cell Al.
PivotTable. 2 =%
A B < D E F G -~ .
The PivotTable Tools are 1 Date Name Destination  Amount Tickets Total Commission 4. Click the Analyze tab.
N . 2 Jan 2 John Harris  Boston 365 30,_| 10,950 Yes
displayed on the ribbon. 3 Jan 3 Tony Chekov Chicago 199 2 398 No 5. Click the Refresh button to see the update reflected in
4 Jan 3 Tim Parmont New York 349 4 1,396 No the PivotTable.
o Click the Analyze tab on the s Jan 3 Antonio Romi Washington, 399 3 1,197 Yes
. 6 Jan 4 Mary Worgot Duluth 149 2 298 Yes
ribbon. 7 Jan5 AmyWu  Dallas 187 2 374 Yes
. 8 Jan 8 LeAnne Nortc Los Angeles 295 6 1,770 Yes
e Click the Refresh button. ° Jan 8 Maria Wyatt Los Angeles 295 7 2,065  No
10 Jan 9 Stan Billings Los Angeles 295 4 1,180 Yes
Tip: A|t +F5 aIso refreshes the 1 Jan 10 John Smith  Chicago 199 2 398 No
. 12 Jan 10 LeAnne ChanyToronto 349 2 698 No
PivotTable. 13 Jan 11 Maria Rodrigt Washington, 399 3 1,197 Yes
14 Jan 14 Alice Lindgrar Chicago 199 2 398 Yes | -
. . . Sales | PivotTable | < v
The PivotTable is refreshed and pullsin |, = H o
any changes made to the source data.
If you have more than one PivotTable T T Putrable Tools
in your workbook and you want to File  Home | Insert Draw  Page Layout | Formulas | Data | Review | View Help ~Analyze Design 0 Tellme @
H H F=l = B insert Sticer = i A
update them all at once, instead click B B - ;‘mzwm ‘B = o B
the Refresh button’s list arrow and Protfavie | Ace | S | g e R s | -
select Refresh All from the menu. By e 2
AL b Fe || sumof Tickets -
A B C D E F 2
1 [sum of Tickets _|Date - 11 PivotTable Fields v X
2 “lJan Choose fields to add to report: &~
2 Destin Al -/2-Jan  3-Jan 4-Jan 5-Jan 8-lan
4 |Boston 3 Search Je
5 |Cancun Date o
6 |Chicago 2 [ Name
7 |Dallas 2 Destination ~
& Duluth 2
s Los AngelES 1 Drag fields between areas below:
10 New York 4 Y Filters 1l Columns
11 |Philadelphia Months -
12 | Toronto = Rows. = Values
13| Washington, D.CIZ 3 Destination - [ [ sumof Tickets  + 1=
14| Grand Total 3 9 2 2 13
» | sales | Pivet .. @ < v Defer Layout Update
Ready i m - 1 + 0%

© 2025 CustomGuide, Inc. 23



V\utomatically Update a PivotTable

You can also have Excel refresh the PivotTables in a workbook when a file opens.

0 Click the PivotTable button on
the Analyze tab.

o Click Options.

The PivotTable Options dialog
box displays. In addition to
setting the PivotTable to
refresh when opened, there
are also various options here
for PivotTable settings, such as

assigning a name; changing the

layout, format, and display
settings; and adding alt text.

e Click the Data tab.

o Check the Refresh data when
opening the file check box.

e Click OK.

Now any PivotTables in the workbook
will automatically refresh each time
you open the file.

i Home | Insert Draw | Page Layout | Formulas Data | Review View Help Al

iz} i) =
PivotTable | Active | Group

- Field - -

PivotTable Name:
PivotTablel
[/3 options -

pigl Tanie

2

3 ination
4 Boston

5 |Cancun

6 |Chicago

7 |Dallas

8 |Duluth

3 |Los Angeles
10 |New York
11 |Philadelphia
12 Toronto

13| Washington, D.C.

14 Grand Total

kets. lDate -

-|2-Jan _ 3-Jan 4-Jan 5-Jan 8-Jan

» | sales | Pivot .. @

Ready

10-refresh-a-pivottable - Excel FivotTable Tools

] Gk || B

Actions | Calculations | Tools | Show

PivotTable Fields
Choose fields to add to report:
Search

Date

[ Name

Destination

Drag fields between areas below:

T Filters | Columns
Months

= Rows = Values

Destination = =1 1] sum of Tickets

Defer Layout Update

B &3 O-— 1

e Design O Tellme

Commented [IG30]:
1. Click the PivotTable button on the Analyze tab.

2. Click Options.
3. Click the Data tab.

4. Check the Refresh data when opening the file check
box.

5. Click OK.

File  Home Insert D

B B -

PivotTable | Active | Group|

- Field - -

AL -

A

4 Boston

5 |Cancun

& Chicago

7 |Dallas

8 |Duluth

9 |Los Angeles
10 |New York
1|Philadelphia
12 | Toronto

13| Washington, D.C.

14 | Grand Total

Layout & Format  Totals & Filters

Retain items deleted from the data source

i |Sum of Tickets |
2

3 Destination -

Number of items to retain perfield: | Automatic |

Enable cell editing in the values area

PivotTable Tools

7 X o O Telime

Printing  Data Al Text Js | Show

Menths

conce || = vaues

» | sates | pivot ... @

Ready

Desiiiation ~ =77 Sum of Tickets

ayout Update

H @ @O-—1

Il Columns
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\Format a PivotTabIe\

Commented [IG31]:
Practice File: 11-format-a-pivottable.xlsx

After creating a PivotTable, you may want to enhance the look of it using styles. By default, the column
headings, grand total row, and any filters have a light shading applied to the cells based on the workbook’s
theme colors. However, if you don'’t like these, there are a variety of other styles to choose from.

‘Work with Style Options

You can select PivotTable style options that allow you to adjust the format for part of a PivotTable. For
example, you can apply special formatting to row headers or make the columns banded.

Click any cell in the PivotTable.
Click the Design tab.

Select an option from the
PivotTable Style Options group.

e Row/Column Headers:
Displays special formatting
for the first row or column
of the PivotTable.

e Banded Rows/Columns:
Applies a different format to
alternate rows or columns.

File  Home | Insert Draw  Page Layout | Formulas | Data | Review View Help

11-format-a-pivottable ~/Bxcel

=Y & General -
meE - S 5-%0

B PR
Clipboard 1 Font 5l Aignment 5l Number
AL bt F< || sumof Amount

A B c D

1 [Sum of Amount |Date -
2| ““Jan  +Feb “Mar GrandTot
3 Destin 2 -
4 Boston 1,460 365 730 2,5
5 |Cancun 199 398 962 1,5
6 |Chicago 597 79% 597 1,9
7 |Dallas 374 374 1,309 2,0
2 Duluth 596 298 596 1,4
¢ |Los Angeles 1,475 590 885 2,9
10| New York 1,047 1,396 3,839 6,2
11 |Philadelphia 399 1,197 399 1,9
12 | Toronto 1,396 1,3
13|Washington, D.C. 1,197 1,197 399 2,7
14 Grand Total 8,740 6,611 9,716 25,0¢ .

» PivotTable | .. & < >

Ready

PivatTable Tools

Analyze Design 0 Telme | &

[ Conditional Formatting = 0
Fe it as Table = y

i Format as Table ¥ Cells | Editing

[ Cell Styles - . -

Styles -
PivotTable Fields T &
Choose fields to add to report:

Scarch
Amount &
Drag fields between areas below:
Filters Columns
Months bod
Rows = Values
Destination bl Sum of Amount Y
Defer Layout Update
B o - 1 + 100

File  Home | Insert Draw Page layout Formulas Data Review V

Subtotals Grand | Report Blank
< Totals~  Layout~ Rows~

Layout

11-format-a-pivottable - Bicel
RowHeaders  [] Banded Rows.
Column Headers [] Banded Columns

PivotTable Style Options

PivotTable Tools.

Help Anayze Design O Tellme

PivotTable Styles

Commented [IG32]:
1. Select cell A1.

2. Click the Design tab.

3. Click the Banded Rows check box to turn on banded
rows.

AL 7 F | sumof Amilat 2
A B c o E ) )

1 [Sum of Amount |Date - PivotTable Fields T %
2 #lan  *Feb Mar GrandTot Choose fields to add to report: & -
3 |Destination -
4 |Boston 1,460 365 730 2,5 Search A
5 |Cancun 199 398 962 1,5

N [ Name -
6 |Chicago 597 796 597 1,9 Db st
7 |Dallas 374 374 1,309 2,0! [¥] Amount A
g |Duluth 596 298 596 1,4
o |Los Angeles 1475 590 885 29 Drag fields between areas below:
10| New York 1,047 1,396 3,839 6,2 Filters Columns
11| Philadelphia 399 1,197 399 1,9 Months -
12 | Toronto 1,396 1,3 Rows E Values
13 |Washington, D.C. 1,197 1,197 399 2,7 Destination ~ 15 | sum of Amount_ ~ 1=
14 |Grand Total 8,740 6,611 9,716 25,0¢ -

s PivotTable | .. & ] v Defer Layout Update
Ready i) mo- ¥ + 100%
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V\pply a Built-In Style

Excel also has a gallery of built-in styles you can choose from to quickly format a PivotTable.

On the Design tab, select an
option in the Styles gallery.

Tip: The PivotTable Styles
group will show a few table
styles, but to see the rest,
you'll need to expand the
gallery.

The style is applied to the table,
changing the borders, shading, and
colors.

Tip: To remove a Table Style, select
Clear from the More PivotTable Styles
menu.

Subtotals Grand Report  Blank
- Totals~ | Layout~ Rows~

Layout

Row Headers

11-format-a-pivottable - Excel

File  Home |Insert Draw Page Layout Formulas Data Review View  Help = Analyze

Banded Rows

Column Headers [] Banded Columns

PivotTable Style Options

Ready

AL 7 f< | Sum of Amount
A ] c D E =

1 [sum of Amount _|Date -
2| “iJan <Feb ©Mar GrandTot
3 Destination v
4 |Boston 1,460 365 730 2,5
5 |Cancun 199 398 962 1,5
6 Chicago 597 796 597 1,9
7 |Dallas 374 374 1,309 2,0
8 | Duluth 596 298 596 1,4
9 Los Angeles 1,475 590 885 2,9
10 New York 1,047 1,396 3,839 6,2
11 | Philadelphia 399 1,197 399 1,9
12 Toronto 1,396 1,3¢
13 \Washington, D.C. 1,197 1,197 399 2,7¢
14 | Grand Total 8,740 6,611 9,716 Zﬂ ~

8 PivotTable | .. (@) 1 v

PivotTable Tools

Design

£ Tellme

@

PiuotTable Styles

4
PivotTable Fields

Choose fields to add to report:

Search

O Name
Destination
Amount

Drag fields between areas below:

Filters
Rows

Destination e | ==
Defer Layout Update

H & M -

Columns.
Months
3 Values

Sum of Amount

Commented [IG33]:
1. Select any style from the PivotTable Styles group.

Be sure to point out that you can click the More button to
see the entire Styles gallery. Hovering over a style’s
thumbnail allows you to preview your PivotTable with that
style.
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